Help with windows service mount

Hello. I have a windows server 2016 and im trying to use a rclone mount with nssm.

I am however not able to get any visible drive in explorer. (i.e. X:) Can anyone show me what im doing wrong?

Using nssm editor i have,
Path: C:\rclone\current\rclone.exe
Start dir: C:\rclone\current
Args: mount gcrypt1: X: --allow-other --cache-db-path="E:\cache_rclone" --max-read-ahead 256M --buffer-size 64M --dir-cache-time 24h --poll-interval 5m --allow-other --allow-root --vfs-cache-mode writes -vvv --log-file=c:\rlonemountservice.log --config="C:\rclone\current\rclone.config"

The service starts successfully but no drive appears. The logfile only shows,
2019/07/11 10:18:07 DEBUG : rclone: Version "v1.48.0" starting with parameters ["C:\\rclone\\current\\rclone.exe" "--config=C:\\rclone\\current\\rclone.config" "mount" "gcrypt1:" "X:" "--allow-other" "--cache-db-path=E:\\cache_rclone" "--max-read-ahead" "256M" "--buffer-size" "64M" "--dir-cache-time" "24h" "--poll-interval" "5m" "--allow-other" "--vfs-cache-mode" "writes" "-vvv" "--log-file=c:\\rlonemountservice.log"]

The windows event log shows,
Started C:\rclone\current\rclone.exe --config="C:\rclone\current\rclone.config" mount gcrypt1: X: --allow-other --cache-db-path="E:\cache_rclone" --max-read-ahead 256M --buffer-size 64M --dir-cache-time 24h --poll-interval 5m --allow-other --vfs-cache-mode writes -vvv --log-file=c:\rlonemountservice.log for service rclone in C:\rclone\current.

What am i doing wrong here?


Edit: the same command works great when running via a cmd-window. But i would like to have a service that starts with windows and so the rclone-mount is visible by all user accounts.

I had a similar problem with NSSM and rclone: I couldn't edit files from the mounted drive and rclone from the command line was working fine. The solution I found was to edit the service and try the "Log on" option with my Windows user.

After that, it worked flawlessly.

I hope it helps.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.