Help with Rclone mount Gdrive / Plex


#1

Hi all,

Hoping you can help as I’m at the end of my tether with my Rclone mount streaming Plex from Gdrive. I’ve been running mounted cache for a while but it often and randomly just starts buffering half way through episodes, it seems so delicate on other things on the network, and whenever the local cache gets full, it completely stops working until I clear some stuff out. So, this last week i’ve switched to VFS off the crypt remote instead… these stream much better throughout, but, my god do they take a long time to get going. 1-3minutes to start a file and don’t dare try to skip ahead\back at any point.

Please help! What am I doing wrong?

Server 2016
i7-7700
16gb RAM
350d/25u

Cache Mount Script:
“C:\Program Files\RClone\rclone.exe” mount --read-only --allow-other --acd-templink-threshold 0 --stats 1s --buffer-size 6G --timeout 5s --contimeout 5s -v --cache-db-path C:\RcloneMount --cache-chunk-path C:\RcloneMount\cache --allow-non-empty --dir-cache-time=48h --vfs-read-chunk-size=128m --vfs-read-chunk-size-limit=4g --buffer-size=1024M --attr-timeout=1s --cache-chunk-total-size 320G --cache-chunk-size 32M --cache-info-age=168h --cache-workers=5 GoogleClone1eCache: Z:

Crypt Mount Script:
“C:\Program Files\RClone\rclone.exe” mount --allow-other --buffer-size 256M --dir-cache-time 72h --drive-chunk-size 32M --timeout 1h --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit off --bind 192.168.0.98 --rc GoogleClone1eCache: Z:


#2

You see to be mixing up commands for certain configs and it’s a bit confusing.

Did you make your client ID/API key?

https://rclone.org/drive/#making-your-own-client-id

If you want to use the cache backed:

C:\RcloneMount\cache --allow-non-empty --dir-cache-time=160h --buffer-size=0M --cache-chunk-total-size 320G --cache-chunk-size 32M --cache-info-age=168h --cache-workers=5 GoogleClone1eCache: Z:

You want 0M buffer as it competes with the cache backend so no reason to have it as it’s overhead. All the other stuff wasn’t needed for cache.

For crypt, that seems fine assuming you have enough memory on the system to support the 256M buffer.


#3

Looks like you’re still using cache in your vfs one. It’s the same remote…


#4

I had no idea about the Client ID/API key! I’ve just set that up and will report back soon!


#5

I was yes as a test, have switched it now and will give it a try!


#6

At first, it seemed like it was working using VFS, but typically sat the wife down to watch an episode, and its stopped working. Looking at logs it seems to be related to the API as per below:

ERROR : IO error: couldn’t list directory: Get https://www.googleapis.com/drive/v3/files?alt=json&fields=files(id%2Cname%2Csize%2Cmd5Checksum%2Ctrashed%2CmodifiedTime%2CcreatedTime%2CmimeType%2Cparents%2CwebViewLink)%2CnextPageToken&pageSize=1000&prettyPrint=false&q=trashed%3Dfalse+and+(‘root’+in+parents)+and+(name%3D’Encrypt’)+and+mimeType%3D’application%2Fvnd.google-apps.folder’: oauth2: cannot fetch token: 401 Unauthorized
Response: {
“error”: “unauthorized_client”,
“error_description”: “Unauthorized”
}

The whole mount is inaccessible. I’ve checked the API creds and they’re fine. Any ideas what I’ve screwed up?


#7

Ah scratch that, looks like I just needed to retoken the remote (for anyone else who ends up here, just run config against top remote and it’ll prompt).

Righto… back to testing…


#8

Very happy to report that since setting up an api, the vfs setup has been working absolutely perfect. Load times under 10 seconds and 0 buffering.

Thanks very much for the help.


#9

Are you able to mark it solved as we added that plugin recently?


closed #10

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.