Help with bisync single drive directory

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

Trying to bisync specific folder named "Uni" in google drive instead of the whole drive

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.1

  • os/version: ubuntu 23.10 (64 bit)
  • os/kernel: 6.5.0-14-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.5
  • go/linking: static
  • go/tags: none

yes

Which cloud storage system are you using? (eg Google Drive)

Google drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone bisync "/home/user/Documents/Uni" drive:"Uni/" --check-access --fast-list --drive-skip-shortcuts --drive-acknowledge-abuse --drive-skip-gdocs --drive-skip-dangling-shortcuts --verbose

result:

Failed to create file system for destination "drive:Uni/": didn't find section in config file

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[Uni]
type = drive
scope = drive
token = XXX
team_drive = 

A log from the command that you were trying to run with the -vv flag

command not found

Hi there!

In the config you posted, the name of your remote is Uni (not drive), so the root of your drive would be Uni: and a subdirectory named "Uni" would be Uni:Uni. Rclone is throwing an error because it is looking for a remote named drive in your config and not finding one.

Since Uni:Uni is probably a little confusing, what I'd recommend is to rename your remote drive, and then your existing command should work.

Another option (after you've renamed) would be to set up an Alias remote named "Uni" pointing to the subfolder drive:Uni, and then you can just use Uni: on the command line.

Also, the first time you run bisync with a new remote, you should add the --resync flag (and then omit it for future runs). Just mentioning it because I didn't see it included in your command :slightly_smiling_face:

The name is indeed an error on my part. I have tried running resync, however after changing the name I get a different problem:
rclone bisync "/home/ohadmartin/Documents/Uni" Uni:"Uni/" --check-access --fast-list --drive-skip-shortcuts --drive-acknowledge-abuse --drive-skip-gdocs --drive-skip-dangling-shortcuts --verbose --resync
2024/01/20 08:01:57 NOTICE: bisync is EXPERIMENTAL. Don't use in production!
2024/01/20 08:01:57 INFO : Synching Path1 "/home/ohadmartin/Documents/Uni/" with Path2 "Uni{YoXec}:Uni/"
2024/01/20 08:01:57 INFO : Copying unique Path2 files to Path1
2024/01/20 08:01:59 INFO : Checking access health
2024/01/20 08:01:59 ERROR : Access test failed: Path1 count 0, Path2 count 0 - RCLONE_TEST
2024/01/20 08:01:59 ERROR : Bisync critical error: check file check failed
2024/01/20 08:01:59 ERROR : Bisync aborted. Must run --resync to recover.

Since you included the --check-access flag, bisync is looking for files named RCLONE_TEST on both sides. It is not finding any, so it is aborting for your safety.

You can fix this by adding an RCLONE_TEST file manually on both sides (more details here). Or alternatively, you can omit the --check-access flag to opt out of this safety feature.

If you did already create the files and bisync is somehow not finding them, let me know and I can help you figure out why!

Thanks! it works now. Have a nice day

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.