Help with assigning permissions to folders, inside of an rclone mount point (google drive storage)

Hey Everyone,

rclone n00be here. I currently have an rclone mount point, (no encryption), from/to my personal Google Drive storage. Everything is working perfectly. If I add/copy a file into this mount point, it quickly shows up in my personal Google Drive storage. This mount point is inside an Ubuntu Server. I’m trying to do a few config changes with a few other apps, which would require a folder that currently exists inside this mount point, to have the following permissions: 0770

The problem is that it appears as though no matter what I do, the permissions aren’t taking with that folder. It’s acting as though the Linux OS permissions aren’t applicable to the Directories inside of the mount point.

Is there any way to accomplish what I’m trying to do, so that I can assign the necessary permission settings to certain folders, inside of that Google Drive Mount Point?



You can’t change permissions or user/group owner in rclone.

You can set:

 --uid uint32                         Override the uid field set by the filesystem.
  --gid uint32                         Override the gid field set by the filesystem.
  --umask int                          Override the permission bits set by the filesystem.

At that point, anything created in Linux will have the items you have configured above with those permissions.