Help! Rclone Mount - Windows


#21

yeah that worked , thanks

now how do you have all this automatically startup on boot without having that cmd stay on screen or minimized beside mssn?

“Edited” i found a simple way
easier way is to create a shortcut of your CMD.exe go to properties and in target type
C:\Windows\System32\cmd.exe -cmd /k cd c:/rclone2 & rclone mount gdrive: Q:
works like a charm , but i’d like the cmd to not stay there on my screen , ill have to dig in deeper

also what does Shortcut.lnk: WriteFileHandle: ReadAt: Can’t read and write to file without --vfs-cache-mode >= minimal error mean ?
thx


#22

hi~
can somebody help me please?
I installed winfsp (along side dokany for cppcryptfs) and I cant use rclone mount.

I have asked in winfsp forum, the author suggest it’s problem from rclone…

Any help appreciated, thanks.

"To my knowledge, yes, although it is not specifically tested.

The error message suggests that rclone fails a statfs call (perhaps the one during initialization, if the mount fails). This looks like an rclone usage problem. I do not know if rclone has changed the mount syntax, but you used to have to specify M: instead of M$ to get the M drive.

Ping @ncw (rclone’s author) who may have some additional pointers."

=====================================
Can winfsp function along side dokany? thx

I got a win7 64b.
Installed cppcryptfs + dokany 1.x to use with google file stream.

Now I wanna rclone mount M$ onedrive to my system,
and rclone mount use winfsp.

I installed winfsp by the .msi installer, installed the signed driver,
everything seems fine but I cannot rclone mount the onedrive.

The error message is
“ERROR: local file system at C:\xxxxxx : statfs failed: failed to read disk usage: the
system cannot find the path specified”.

googled but dont found useful things.

in winfsp FAQ, it demo problem when dis mounting the winfsp, when there is a dokany install.
so the FAQ say both can be installed, just with problem when dismounting. … not my case.
the winfsp google group … i cant even post there.
So I ask here and hope someone could help.

thanks

https://github.com/billziss-gh/winfsp/issues/205


#23

Hi~

completely my fault!

Just re-read and found that the remote need a “:”.

refer to this post from author:

rclone mount gdrive: Q:

I missed the “:” in the gdrive.

Thank all, my problem get solved. thanks.