Google Team Drive copy results in new folder in My Drive

What is the problem you are having with rclone?

Trying to copy a local folder to a subfolder of a Google Shared/Team Drive, I either can't get he syntax right or I'm using the wrong syntax and end up with either a 4xx error (GoogleSide) or the Directories get created individually under My Drive

What is your rclone version (output from rclone version)

The latest version I can use on macOS 10.10, rclone v1.54.1

  • os/arch: darwin/amd64
  • go version: go1.15.8

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy -v --drive-impersonate "/Volumes/vTrakRAID/Dropzone/JOBS 2019" "drivemig:--drive-team-drive <DRIVEID_String>"

The rclone config contents with secrets removed.

type = drive
scope = drive
service_account_file = /path_to.json

I've also tried adding the
team_drive = <DRIVEID_String
to the end

But I just can't seem to get the Syntax right to copy the whole directory 'JOBS 2019' (not subfolders) to a subfolder of the TeamDrive , e.g. TeamDrive/Company_Dept/

Any assistance much appreciated

You have an old version and you should update that.

I'm confused though as it drivemig a drive or a team drive? You can configure a new team drive by running rclone config and picking a team drive through the process.

It looks like you are trying to copy to a regular drive but trying to force it to be a team drive.

Thanks for taking the time.

To start with the version - as said the version is the last that will run without crashing on launch on this OS. So that’s a fixed point

The drivemig is the name of the configuration I’m using, and yes the destination is a Google Team Drive

That doesn't seem to make sense offhand. What's the error when you run it?

As I said, that's not configured a team drive. Configure a remote with a team drive.

You have a remote configured as team drive:


crash log is here from installing the latest:

this applies to all versions post 1.54.1, which seems to be when the arm/amd64 split happened)

as to the Team Drive configuration, I'm confused !!
I went to edit the config and it clearly shows a Team Drive ID, and at the end of the edit process, asks if I want to change the ID:

type = drive
scope = drive
service_account_file = /Users/sadmin/<STRING..json
team_drive = <TEAM_DRIVE ID String>
y) Yes this is OK (default)
e) Edit this remote
d) Delete this remote
Remote config
Change current Shared Drive (Team Drive) ID "<TEAM_DRIVE ID String>"?
y) Yes
n) No (default)

So is it just my rclone command syntax which is off here, or have I completely misconfigured the 'drivemig' remote?

What is the output of the rclone version from that log?

For the team drive, you want to pick yes for team drive and your rclone.conf should look like:

And just do a simple test to validate things work.

etexter@seraphite ~ % rclone copy /etc/hosts TD:
etexter@seraphite ~ % rclone ls TD: -vv
2021/10/17 10:59:25 DEBUG : rclone: Version "v1.56.2" starting with parameters ["rclone" "ls" "TD:" "-vv"]
2021/10/17 10:59:25 DEBUG : Creating backend with remote "TD:"
2021/10/17 10:59:25 DEBUG : Using config file from "/Users/etexter/.config/rclone/rclone.conf"
      366 hosts
2021/10/17 10:59:26 DEBUG : 6 go routines active

Oh, sorry I didn't realize that version was that old.

10.10 dropped out of support Aug-2017 so that's why. I thought it was an OS back.

No need to share a version or anything else as that's not supported on newer versions.

That worked! missing out all the API stuff and just using the web OAUTH and specifying the root folder in the config by its ID

So, thank you, although this method will be slower than using the API that's OK . However one last question:
What syntax do I use to copy LOCALFolder1 to REMOTESUBFolder1 of the remote (where the root is defined as REMOTEFolder?)

Thanks as always

1 Like

Never mind! Figured it out - there was a quote/space in filename issue. Brilliant!!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.