Google Photos: what does this mean?

I have had this constant output since the 19th, where I had 3 video files. I am using the sync option with rclone. Why does rclone always say it's transferring these 3 files only? It doesn't look like it is actually transferring as these files already exist in the destination folder.

2019/09/26 15:30:08 INFO : Local file system at /sharedfolders/GooglePhotos/2019/September: Waiting for checks to finish
2019/09/26 15:30:08 INFO : Local file system at /sharedfolders/GooglePhotos/2019/September: Waiting for transfers to finish
2019/09/26 15:31:01 INFO :
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors: 0
Checks: 408 / 408, 100%
Transferred: 0 / 3, 0%
Elapsed time: 52.6s
Transferring:

  •                   VID_20190919_141237.mp4: transferring
    
  •                   VID_20190919_141313.mp4: transferring
    
  •                   VID_20190920_202420.mp4: transferring
    

2019/09/26 15:32:01 INFO :
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors: 0
Checks: 408 / 408, 100%
Transferred: 0 / 3, 0%
Elapsed time: 1m52.6s
Transferring:

  •                   VID_20190919_141237.mp4: transferring
    
  •                   VID_20190919_141313.mp4: transferring
    
  •                   VID_20190920_202420.mp4: transferring
    

The above repeats itself many times, then after a while:

2019/09/26 16:30:01 INFO :
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors: 0
Checks: 408 / 408, 100%
Transferred: 0 / 3, 0%
Elapsed time: 59m52.6s
Transferring:

  •                   VID_20190919_141237.mp4: transferring
    
  •                   VID_20190919_141313.mp4: transferring
    
  •                   VID_20190920_202420.mp4: transferring
    

2019/09/26 16:30:02 ERROR : VID_20190919_141237.mp4: Failed to copy: failed to open source object: Error 403 (Forbidden)!!1{margin:0;padding:0}html,code{font:15px/22px arial,sans-serif}html{background:#fff;color:#222;padding:15px}body{margin:7% auto 0;max-width:390px;min-height:180px;padding:30px 0 15px} > body{background:url(//www.google.com/images/errors/robot.png) 100% 5px no-repeat;padding-right:205px}p{margin:11px 0 22px;overflow:hidden}ins{color:#777;text-decoration:none}a img{border:0}@media screen and (max-width:772px){body{background:none;margin-top:0;max-width:none;padding-right:0}}#logo{background:url(//www.google.com/images/branding/googlelogo/1x/googlelogo_color_150x54dp.png) no-repeat;margin-left:-5px}@media only screen and (min-resolution:192dpi){#logo{background:url(//www.google.com/images/branding/googlelogo/2x/go
oglelogo_color_150x54dp.png) no-repeat 0% 0%/100% 100%;-moz-border-image:url(//www.google.com/images/branding/googlelogo/2x/googlelogo_color_150x54dp.png) 0}}@media only screen and (-webkit-min-device-pixel-ratio:2){#logo{background:url(//www.google.com/images/branding/googlelogo/2x/googlelogo_color_150x54dp.png) no-repeat;-webkit-background-size:100% 100%}}#logo{display:inline-block;height:54px;width:150px}

403. That’s an error.

Your client does not have permission to get URL /lr/AGWb-e4SgXEIajaMfOqHutTG63iIPc2acb4zCF2tN-o2g4BMLNBPgtYm26nqB6HStHtQqqST_SRbsxb3O2M_HNr1XlsqI0rYmNDr5PUTJOpuyifJf-WzYaGV2VSPz8cW5F1Mq_oo2g3kE-uji4g8N_HwJRXiglE5_ys47lUYZfjF-LzlGwMJgtRloxnC5GH4VrGIvJJJhEeCvhon73TvgE-7Ygni3gKKrmCbKE-UZ_EFMsB3dHrlLx11CfORPpvLcUf2HIUes0kY2gMSLb6feCstMNXh8d3rHB6cT7KevVpPoY76uEEUf0ajYtj61yGdJelEb7BUW66O-arLWGNHiA5JI03zuCXkuh3txh8k7qeFGxViN19AwCg9ma-rN2F5Po5JRuPf5125_QYDhsJm
mUw9fqtQqyFZvThbL_KDwn6ybkcZeYIl8aM-jyJ0957WuL61ku1xafOROkAN5FqWEFDzrVV6OrnfNWLbHjxpgIAiSJ_IjcjjsWixDnZBbjIUaLqL_rkL2xa1_D4zJGtIVwaiqvmgGh6SE9szrGtd9ROkDz4O6HSMri2UarvLiiZ2R5K2s1dj--t4PaSgPnFRDDTax0rf9s6Z9oGxbl4bwwGRbR3_ubaJOi-0PUtRBI_CgJiJO-cKNmPjtu9y0V4xOAHXoVwKQq83Lb43_mPTw9s7BpXhQcspcZTFDjHSQzwapxatwNrNsxjUaBpqpcqC8M9lsOZhbciaA3moSgPy6slYOLCKvmQXB5ZgCCpxTcndhuqukj-FEacM8P40iVmfb9eD5cvB87TSLU60awl0P3YiSN3SgIFTSFW5F1ztvVmoWzC5h1H9qfzFUXZgNlUKLO1vVrLvcK2tA_gMgPdF0gzitWTG_qElUIWWdXC8rMN0DygXFgxKTlq-CcQMMXCtU8pWO3GOVRov3w=dv
from this server. (Client IP address: x.x.x.x)

Where are you copying from / to?

Can you show the rclone command line you are using?

Which version?

The behavior indicates the files are trying to transfer - but get stuck in a loop of low-level retries.
This is almost certainly why it seems to stall for while before you finally get the error.

Because Cloud APis are not 100% reliable, rclone always retries many times (adjustable) before it gives up and throws an error about it. In this case though it's clearly not a problem that can be solved by retries.

403 unfortunately does not tell us much, as that includes a whole category of errors - but this seems like a permission issue based on the error-text.

Unfortunately I do not have a lot of personal experience with the Google Photos backend. I think it is fairly new and still has some quirks to it. I'd probably advice taking a look at the several recent threads ab out it to see if someone had the same problem (likely):
https://forum.rclone.org/search?q=google%20photos%20order%3Alatest

But now that NCW answered while I was away - he's your best source obviously. He wrote it after all :slight_smile: