Google Drive union creates local folders with files for each remote

What is the problem you are having with rclone?

Trying various configurations for setting up a union of ten Google Drive accounts mounted as "DiskG". Rclone creates a local folder for each remote in the union in the rclone folder. So having a mounted union consisting of ten remotes generates ten local folders, each containing the one test file I copied to DiskG. Why is that and is it expected behaviour?

Tested with different settings for:
--vfs-cache-mode (thought it could be a caching issue)
--vfs-cache-max-age 0h10m0s (thought it could be a caching age issue)
--cache-dir C:\temp (thought it could be a caching folder issue)

What is your rclone version (output from rclone version)

rclone v1.56.2

  • os/version: Microsoft Windows 10 Pro 2009 (64 bit)
  • os/kernel: 10.0.19042.1237 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.16.8
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe mount DiskG: G: --config C:\Users\r\ent\par\ker\Rclone\rclone.conf --log-level DEBUG --log-file C:\Users\r\ent\par\ker\Rclone\rclone_log --use-json-log --cache-dir C:\temp --disable About

The rclone config contents with secrets removed.

[Disk1]
type = drive
client_id = xxx.apps.googleusercontent.com
client_secret = xxx
scope = drive
token = {"access_token":"xxx","token_type":"Bearer","refresh_token":"xxx","expiry":"2021-10-01T11:14:50.7896115+02:00"}
team_drive = 

[Disk2]
Same as Disk1 except token

[Disk3]
Same as Disk1 except token

[Disk4]
Same as Disk1 except token

[Disk5]
Same as Disk1 except token

[Disk6]
Same as Disk1 except token

[Disk7]
Same as Disk1 except token

[Disk8]
Same as Disk1 except token

[Disk9]
Same as Disk1 except token

[Disk10]
Same as Disk1 except token

[DiskG]
type = union
upstreams = Disk1 Disk2 Disk3 Disk4 Disk5 Disk6 Disk7 Disk8 Disk9 Disk10
action_policy = all
create_policy = all

A log from the command with the -vv flag

https://pastebin.com/TeEbmag5

You need : on the end of those Disk1: otherwise you are accessing a local directory, so

upstreams = Disk1: Disk2: Disk3: Disk4: Disk5: Disk6: Disk7: Disk8: Disk9: Disk10:
1 Like