Google drive (shared drive) rate limit makes it impossible to upload

What is the problem you are having with rclone?

So I've been attempting to utilize rclone on a Google Drive shared drive that has unlimited storage. However, whenever I use it, I receive the following error: Error 403: The user rate limit has been exceeded, userRateLimitExceeded. I also did some research to see if anyone else had this problem and discovered that I should create my own client id, which I did by following these instructions Google drive but when I tried again, I still got the errors, so I tried the --fast-list flag but that didn't help the folder I am uploading is around 7gb so I shouldn't be reaching the 700gb daily max. I also tried uploading it using rclone to my regular root Google Drive and it worked fine, but I'd prefer to do it on my shared drive. Another thing to note is that the speed at which rclone would upload files to my root drive was WAY faster than when I tried to upload them to a shared drive. which went from a 20min upload to about 3 days for only 6.035gb

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1

  • os/version: oracle 8.8 (64 bit)
  • os/kernel: 5.15.0-103.114.4.el8uek.aarch64 (aarch64)
  • os/type: linux
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.20.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive (shared)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy -P -vv --log-file=mylogfile.txt glicky mc:glicky

The rclone config contents with secrets removed.

[mc]
type = drive
client_id = 685368628905-jnno98o9gt0460lkebhd239100pa14vb.apps.googleusercontent.com
client_secret = jibberish
scope = drive
token = {"access_token":"jibberish","token_type":"Bearer","refresh_token":"jibberish","expiry":"2023-08-23T22:02:04.896934766Z"}
team_drive = jibberish
root_folder_id = 

[gdrive]
type = drive
client_id = 685368628905-jnno98o9gt0460lkebhd239100pa14vb.apps.googleusercontent.com
client_secret = jibberish
scope = drive
token = {"access_token":"ya29.ajibberish","token_type":"Bearer","refresh_token":"jibberish","expiry":"2023-08-23T16:56:52.8019788-04:00"}
team_drive = 

A log from the command with the -vv flag

https://pastebin.com/P7CNSiNi

Are you aware that Google Drive no longer offer unlimited storage, and they have sent out e-mails placing people in a grace period, which is a read-only state.

This is likely what you are encountering.

1 Like

Oh wow I actually had no Idea thank you so much I will have to end up looking for an alternative then thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.