Google Drive: add ability to stop on storageQuotaExceeded

What is the problem you are having with rclone?

I scheduled a backup job, but my shared drive storage reached its maximum capacity. I expected rclone to fail fast, but instead, it continued to retry when it encountered "storageQuotaExceeded" errors.

Is there any flag to force it to stop rather than retry? Something similar to --drive-stop-on-upload-limit.

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.1
- os/version: darwin 12.6.3 (64 bit)
- os/kernel: 21.6.0 (arm64)
- os/type: darwin
- os/arch: arm64
- go/version: go1.19.3
- go/linking: dynamic
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /tmp remote:tmp --drive-stop-on-upload-limit

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

<3>ERROR : Failed to copy: googleapi: Error 403: The user's Drive storage quota has been exceeded., storageQuotaExceeded

It would seem reasonable to treat storageQuotaExceeded the same as quotaExceeded if you wanted to send a pull request? Then the upload limit would work.

Why google have two such similar error names I don't know!

A PR have just been opened. Please review

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.