Getting 429 copying to my own repository

What is the problem you are having with rclone?

Getting 429 when using rclone copy to copy to or from my own Box account.
Is there any way to configure rclone to bypass the Box rate limit (240 uploads/min/user, 1000 requests/min/user), currently resulting in 429 (rate limit exceeded) errors, when copying large numbers of files that I own to or from my BOX account.

Please advise, thanks.

Run the command 'rclone version' and share the full output of the command.

$ rclone version
rclone v1.49.3

  • os/arch: linux/amd64
  • go version: go1.12.9

Which cloud storage system are you using? (eg Google Drive)

BOX

The command you were trying to run (eg rclone copy /tmp remote:tmp)

# the following results in multiple 429 failures, copying ~1M files
rclone copy -v <remote box account> <local target>
# the following is expected to take ~3 days
rclone copy -v --tpslimit 4 <remote box account> <local target>

The rclone config contents with secrets removed.

$ rclone config show
[<redacted>]
type = box
token = {"access_token":"<redacted>","token_type":"bearer","refresh_token":"<redacted>","expiry":"2022-05-04T16:14:25.285388424-05:00"}
box_config_file = ~/.config/rclone/139341__config.json
box_sub_type = enterprise

A log from the command with the -vv flag

# Many files fail after 1/3, 2/3, and 3/3 retry attempts with 429 (rate limit exceeded)

That version is ancient.

You probably want to update and try again.

You can't bypass the rate limits.

Rclone normally retries 429 errors - is it not?

You can also set --tpslimit to try to slow rclone down. --tpslimit 16 is about 1000 requests/minute