Gdrive backend with minio server

Just for kicks, i thought i'ld try running minio server on a gdrive backed rclone mount (mainly because i have unlimited gdrive storage space from my employer).

unsurprisingly, it didn't work, with minio claiminig it doesn't have the correct permissions

/data # minio server /data/XXXX/
ERROR Unable to initialize backend: Unable to write to the backend
      > Please ensure MinIO binary has write permissions for the backend
        Use 'sudo chown root /data/XXXX && sudo chmod u+rxw /data/XXXX' to provide sufficient permissions.

according to minio/issues/5046 is because the fuse implementation is not posix compliant. any chance of making it at least appear so?

I think that is a genuine permissions error.

Maybe you need --allow-other on your mount?

i already had --allow-other :frowning_face: i also tried --allow-root and various umask values too. i can write to the mounted directory fine as the same user as the minio instance - but minio always reports back the above error.

@ncw - can this item be solved via rclone or is that a change in the fuse library?

That link has the item in question that does not work on a fuse system.

I had a little play with this.

Adding --vfs-cache-mode minimal fixed the problem for me. You might need to upgrade that to writes

That isn't ideal - I would have thought minio should work without read/write access to the objects but see how it goes!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.