GDrive 403 Error out of no where

What is the problem you are having with rclone?

I've had my Plex/ Rclone setup running for quite some time now and all of a sudden starting a few days ago, I'm getting the 403 error. No changes have been made to any of my services. Is anyone else starting to see any issues?

I'm not uploading a lot, so it's not the 750 GB.
I don't think I'm hitting the api limits:

Can anyone help me figure this out please, thanks.

What is your rclone version (output from rclone version)

1.48.0

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 64bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --rc --allow-other --dir-cache-time 96h --buffer-size=8G --vfs-read-chunk-size=128M --vfs-read-chunk-size-limit off --log-level DEBUG --log-file D:\RCLONE\rclone.log --cache-dir D:\RCLONE\ --fast-list --timeout 1h --vfs-cache-mode writes --tpslimit 4 NewDrive: G:

The rclone config contents with secrets removed.

[NewDrive]
type = drive
client_id = 
client_secret = 
scope = drive
token =

A log from the command with the -vv flag

https://pastebin.com/embed_iframe/mefTgJ9r

hello,

  • that version is over a year old, so update and test again.

Yes I have my own ID.

I just updated to the newest version. Will have to wait until tomorrow to see if that was the issue.

what version did you update to?
what command are you running?

Updated to: 1.52.2

I apologize, just realized my post is not clear at all.

I'm using this to mount:
rclone mount --rc --allow-other --dir-cache-time 96h --buffer-size=8G --vfs-read-chunk-size=128M --vfs-read-chunk-size-limit off --log-level DEBUG --log-file D:\RCLONE\rclone.log --cache-dir D:\RCLONE\ --fast-list --timeout 1h --vfs-cache-mode writes --tpslimit 4 NewDrive: G:

This is for my Plex setup. Everything was running fine and now all of a sudden I started getting the 403 error.

not sure what the exact issue is, not a gdrive expert, but we have plenty of them, who will stop by.
is this remote shared with others?

i would be sure that you understand each and every flag and if it is needed.

  • --allow-other does nothing on windows so you can remove it.
  • --fast-list does nothng on a mount, so you can remove it

Not a shared drive. Only this mount has access. Thanks for the info. I'll update my command.

make sure that anti-virus programs are excluding the drive letter from scans.

for what it worth, when i stream from a mount, i use almost none of those flags, never found a reason for more

rclone mount --dir-cache-time 96h --log-level DEBUG --log-file D:\RCLONE\rclone.log NewDrive: G: --read-only

Here is the error

  1. 2020/08/02 12:12:03 ERROR : video.mkv: ReadFileHandle.Read error: low level retry 1/10: open file failed: googleapi: Error 403: The download quota for this file has been exceeded., downloadQuotaExceeded

The cause is that downloadQuotaExceeded - that means that file has blown its download quota. It resets in 24 hours though.

That's the issue. I just just gotten the 24 hour reset. It happened again after only playing 2 shows on plex.

did you try my simplified mount command?

in all my years of mounts and media streaming, never used that flag
are you sure you need that flag?

This is not resolved. The point is I've been running this same setup for over a year. Last 3 days I keep getting 24 bans. Trying to find the cause. No change to Plex/Rclone.

from the log, it looks like in just a few minutes, this file was downloaded twice.

2020/08/02 09:46:59 INFO  : Movies/The Jesus Rolls (2019)/The Jesus Rolls 2019 WEBDL-1080p.mkv: Copied (new)
2020/08/02 09:50:45 INFO  : Movies/The Jesus Rolls (2019)/The Jesus Rolls 2019 WEBDL-1080p.mkv: Copied (replaced existing)

That buffer size is just nuts. Try something like this to see if it helps:

rclone mount --attr-timeout 1000h --dir-cache-time 1000h --poll-interval 0 --rc --read-only --vfs-read-chunk-size 32M -v

Note that this is a read-only mount. If you need write access, use this:

rclone mount --dir-cache-time 1000h --poll-interval 15s --rc --vfs-read-chunk-size 32M -v

1 Like

Did you upgrade Plex recently? Intros on? Something else turned on?

1 Like

I think plex updated a couple of weeks ago with intro. I've turned it off today. Let's see if that makes a difference.

Update: seems to be ok after half day.