Fuse FS Create/LastModify time not editable

What is the problem you are having with rclone?

Trying to modify/edit/change the File MetaData over Rclone FileSystem

I am using the Computer command of set File MetaData
System.Io.File -> SetCreationTime and SetLastWriteTime

But it not affected the File over the "Local Drive".

If I change it from the Sync Software (of koofr) it changes the file property.
I wonder why is not working with that

Some Example

$date= [datetime] '01/01/1990'
write-host "New Date: $($date)"
$path = "K:\New Text Document.txt"

write-host "New ModifyTime: $([System.IO.File]::GetLastWriteTime($path))"
write-host "New CreationTime: $([System.IO.File]::GetCreationTime($path))"

What is your rclone version (output from rclone version)

  • rclone v1.56.0
  • os/version: Microsoft Windows 10 Enterprise 1909 (64 bit)
  • os/kernel: 10.0.18363.1734 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.16.5
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

D:\Software\rclone\rclone.exe mount --vfs-cache-mode full koofr: K:

The rclone config contents with secrets removed.

what is this???

A log from the command with the -vv flag

for this, I need to run the command with -vv in the end???
and if yes, where will be the log file?

Hi, welcome to the forum!

Its the output from running command rclone config show, but with passwords, tokens and other sensitive information removed.

Correct. With -vv it will just print more information to the command window where you run the mount command. If you rather want the output to a file, also use something like --log-file=logfile.txt (see: Documentation)

I can reproduce your issue.

I think it is a limitation when working with certain backends: Those that do not support directly updating ModTime. Koofr is such a backend, also Jottacloud which I tested with. Normal rclone copy/rclone sync will work around this by re-uploading the file, but not the mount. I'm not sure if it is a bug or a limitation, or something in between... :slight_smile: I've created an issue for it on github, so hopefully someone will enlighten us either here or there...

If a backend doesn't support SetModTime then you can't change the modification time of a file without re-uploading it.

However it looks like koofr may support it now if their sync software supports it and all we need to do is implement it in rclone.

The problem, from a user's perspective, is that SetModTime support is not directly documented. Also some commands, like copy and sync, will re-upload automatically if backend does not support SetModTime, so it's easy to miss. (We have issue 1066 for improving documentation on this).

Seems one can use rclone touch on an existing file to check the support:

rclone.exe touch remote:/existing_file.txt
2021/09/26 19:20:02 ERROR : Attempt 1/3 failed with 1 errors and: touch: couldn't set mod time: can't set modified time
2021/09/26 19:20:02 ERROR : Attempt 2/3 failed with 1 errors and: touch: couldn't set mod time: can't set modified time
2021/09/26 19:20:02 ERROR : Attempt 3/3 failed with 1 errors and: touch: couldn't set mod time: can't set modified time
2021/09/26 19:20:02 Failed to touch: touch: couldn't set mod time: can't set modified time

Hey there.
Thank you for Respond
About the first

type = koofr
user = <MyEmail@domain.com>

About the second
Cant upload so SomePasteBin

About the git, thank you.
I am following

Now I see in the git forum
that they Tagged it as bugged ^^
Thank you very much <3

It is an option?
I understand from Koofr Document, that it uses the Koofr API.
So I don't really understand how possible the edit it from rclone "implement it in rclone."?
If it is possible It be Great! ^^

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.