FR: Increased error reporting for union feature

Could there be scope to increase error logging/reporting for union? Essentially to alert to fat-finger user error!

I have a union with maybe a dozen mount points. e,g remote:dir/dir2 and they can be quite long with similar names so to appear unified when mounted.

I had not noticed that some later additions had the form remote/dir1/dir2 and the drive happily worked and mounted, but obviously it did not include the remote/dir1/dir2 entries. Quite rightly so.

If it is possible, and I don't know where (when the config is monitored a "sanity check" or at least on mount - hey, not all dirs can be seen - copied over to systemctl as that's how I mount) would be great if possible.

Mind you, it could be a niche feature if most people don't have poor eyesight, fat fingers and lots of mounts!

Thanks for any consideration, anyway.

I recently merged a freature which will give you a warning if you used remote rather than remote: - I don't think this will help with your use case quite though.

Is it just that you forgot the : on remote?

In my case I had several remote:path entries which worked and then added several remote/path (cut and pasted from mounted drive To make a union collection). Forget to change / to : and merged all together. Not helped by my poor vision. Added to config (updated) & verified with rclone lsd unionname:and got no error. Only discovered after a couple of weeks the union was "incomplete' and the reason wasn't obvious for a time.

Getting an error somewhere (on creation, or on test) could have been nice. Even with a typo elsewhere some error would be good, E.g can't access (faulty path) in union would be nice, a sort of file not found.

I don't pretend to know if it is easy to possibly implement, but I thought I'd throw it out just in case.

The trouble is, is that you pointed the union members to local directories which is perfectly valid - that is why it didn't give an error. Rclone will have created the directory and stored files in it :frowning:

Ah, a perfect storm of issues. Would it be possible to somehow detect that "nothing" is retrieved from some elements in a union? So you may still get the warning that something is not right? Mind you, that might clash with setting up a new union. Hmm, a --verify type flag?

In any case, I fixed the error of my making. Luckily too it was a read-only union!

Hi Darren,

You could place an ID file in the top folder of each of the unioned remotes. Then you can do something like this to quickly check that everything is OK:

> rclone ls yourUnion: --include="/ID_*"
ID_01_remoteA_dir1
ID_02_remoteA_dir2
ID_03_remoteB
ID_04_remoteC

Will investigate that, thanks.