For anyone having error 404 file not found setting up teamD and Drive

What is the problem you are having with rclone?

SOLVED*****Error 404: file not found during set up *********SOLVED

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

ubuntu 18.04

Which cloud storage system are you using? (eg Google Drive)

Google team drive (g-suite enterprise)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rlclone config

Paste command here

I was trying to use oauth with a cloud seed box in Europe and I was not validating against a domain I owned, so I had no way of providing the uri to approve validation. I was unsuccessfully attempting to use a service account file and -drive-impersonate flag

The rclone config contents with secrets removed.

Paste config here

BOTTOM LINE IS MAKE SURE YOU SET UP YOUR OAUTH CONSENT SCREEN WITH USER TYPE EXTERNAL NOT (INTERNAL) which is clearly indicated in the instruction. I am hoping that if anyone is having this error just make sure you validate this step. I have set up oauth hundreds of times and should have make this check initially. 4 hours later and bald spot where my hair used to be I started a new project in GCE and worked right out of the gate. I did learn alot about rclone last night so not at all a loss of time.. Awesome Forum

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

so you followed the documented instructions and it worked?

yes, rclone is awesome and so is its forum.

Thank you for the welcome.. Yes, some how when I was setting up the google Oauth which I have done quite a few time over the years and selected Internal instead of external.. Oddly enough the remote connected to my Google Drive, but it would pull down my team drive, that's why I didnt bother to redo the key..

thanks again for the warm welcome

Are you a moderator can you marked as solved?

I use internal and works fine for me.

It only depends on where the users are:

In this mode, your app is limited to G Suite users within your organization.

as that's internal. If you external user's you'd have to use external.

That's why it worked for my drive files, makes sense now. I was trying to link to my movie collection which is on a shared drive.. Shared drives if set up correctly will increase your daily download limits depending on how many user you add to it.. I Discovered Google has a daily upload limit of 750GB per user all drives combined but if you make multiple service (SA) accounts you can effectively increase your daily limits by using the shared drives..

i am not the moderator, just a fellow rcloner.

i did not solve the problem, you did.
you should be able to mark it solved, no need for me to do it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.