Files not downloading via rclone mount

So I’ve had my rclone mount running for months with a mount checking script checking if it’s up at all times, but just today I cannot download anything specifically from the mount on my vps. If I run a command like rclone copy gsuite:/acd/NAS\ the file will download, but if I try to access the file via the same mount it will not download. Does anyone have any ideas why this might happen or any tips to help me troubleshoot this issue?

Also, this is an issue specific to my vps and that’s why I’m having trouble figuring it out, if I mount the drive on my laptop it works flawlessly.

Are there any logs? Check dmesg also to see if the kernel is complaining about anything.

Is rclone mount using a lot of memory or CPU?

Have you tried restarting the mount &or restarting the VPS?

I’ll try restarting the server yes. I don’t have access to dmesg because of the way the server is segmented between other users. Here is a screenshot of rclones cpu usage when I use top I had just restarted the mounts about a minute ago when I took that screenshot. I tried to set --logfiles /mnt/mpathi/xxxx/file.log as one of the paramaters for the mount but it spits out Fatal error: unknown flag: --logfiles

I actually have messaged my vps provider about the issue and they replied with this,

We're having some IPv6 connectivity issues with Google. Forcing IPv4 will get around this, however I'm not seeing any switch available for rclone to force IPv4. I'll look into this some more and see if I can figure out a solution for you.

There isn’t a switch to force IPv4. You can use the --bind flag (in 1.38) to gind to an IPv4 address which will do it though.

1 Like

@qrenz, use this:

Mentioned it to another person recently. A few of us managed to get the unionfs working. So avoid using a mount, rather use the sync with the bwlimits built in. Hope it helps. This is geared towards google drive, so I hope it helps acd.