Files-from not working

I am trying to copy a lot of files to an rclone remote, and I have had success with using files-from in the past, but for some reason it isn't working for me now. I am running the following command:

rclone copy --files-from "D:/add_gcrypt/textfile.txt" "D:/add_gcrypt" "Gsuite_Crypt:Dropbox/"

When I execute rclone ls after running this, the files appear not to have been copied into the remote, but I get no errors. Is there a mistake I have made with using this command?

can you post the textfile.txt.
and the log with debug info, just at -vv to your command for debug output




rclone copy --files-from "D:\add_gcrypt\textfile2.txt" "D:\add_gcrypt\from" "GSuite_Crypt:/Dropbox/" -vv
2020/03/20 13:40:03 DEBUG : rclone: Version "v1.50.2" starting with parameters ["rclone" "copy" "--files-from" "D:\\add_gcrypt\\textfile2.txt" "D:\\add_gcrypt\\from" "GSuite_Crypt:/Dropbox/" "-vv"]
2020/03/20 13:40:03 DEBUG : Using config file from "C:\\Users\\Callum Stewart\\.config\\rclone\\rclone.conf"
2020/03/20 13:40:05 DEBUG : p3.txt: Excluded
2020/03/20 13:40:05 DEBUG : p1.txt: Excluded
2020/03/20 13:40:05 DEBUG : p2.txt: Excluded
2020/03/20 13:40:06 DEBUG : Zipped Archives: Excluded
2020/03/20 13:40:06 INFO  : Encrypted drive 'GSuite_Crypt:/Dropbox/': Waiting for checks to finish
2020/03/20 13:40:06 INFO  : Encrypted drive 'GSuite_Crypt:/Dropbox/': Waiting for transfers to finish
2020/03/20 13:40:06 INFO  :
Transferred:             0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors:                  0
Checks:                  0 / 0, -
Transferred:             0 / 0, -
Elapsed time:            0s

2020/03/20 13:40:06 DEBUG : 7 go routines active
2020/03/20 13:40:06 DEBUG : rclone: Version "v1.50.2" finishing with parameters ["rclone" "copy" "--files-from" "D:\\add_gcrypt\\textfile2.txt" "D:\\add_gcrypt\\from" "GSuite_Crypt:/Dropbox/" "-vv"]

I have deleted some of the debug information because it isn't relevant, and reveals things I'd rather not. But the things that I deleted are folders that have the form date time DEBUG : folder: Excluded

1 Like
  1. remove the quotes from the entries in the textfile.

  2. and you are using an old version of rclone, please consider updating.

Is there a way I can list only the files ending in .txt inside the directory so I can see if they were copied successfully? I tried:

rclone ls "GSuite_Crypt:Dropbox" | grep *.txt

but I get no output. Also, I removed the quotes, and it still doesn't work.

i am getting confused, as you changed your rclone command from

rclone copy --files-from "D:/add_gcrypt/textfile.txt" "D:/add_gcrypt" "Gsuite_Crypt:Dropbox/"


rclone copy --files-from "D:\add_gcrypt\textfile2.txt" "D:\add_gcrypt\from" "GSuite_Crypt:/Dropbox/" vv

all filters are relative to the root of the source, not the abolute path of the source file.
your root is D:/add_gcrypt
so in the first command, change the textfile to


Ah, I've been undone by relative file paths! I always seem to get mixed up with those! So if I include only the filenames in the textfile.txt, then that will look for the files in the path D:\add_gcrypt\from\, meaning that it's the same as writing the full path in the textfile.txt, and having the source directory as just D:, am I right?

files are relative to your root. Im not a windows guy but remove the d:\folder\ from the files in your text file so they match your root you've specified.

everybody gets mixed up that way.

the paths, if any, on the include file, are relative to the path of the source.
the source path is D:\add_gcrypt\from\
so having p1.txt in the include file is treated as
D:\add_gcrypt\from\ + p1.txt
which is

you should use the --dry-run flag for testing

That's what I suspected. So to do what I was trying to do, I would need to run

rclone copy --files-from "D:/add_gcrypt/textfile.txt" "D:/add_gcrypt/from" "GSuite_Crypt:Dropbox/testdir"

and have the textfile as


because that will look for the files in the paths


but you can try it yourself, juse use --dry-run and read the output.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.