Files are not visible even with --allow-other and -uid

#1

I have a web UI that allow me to pick files on my linux server. But it does not see the mount after mounting it.

I'm using --allow-other, have it on /etc/fuse.conf, and have -uid to be the same user as the user running the web UI.

I'm lost here, it can't be a permission issue right? I'm on ubuntu 14.04 and using google drive btw, with latest rclone

#2

What is the command you are using? Can you recreate the problem with "-vv" and share the log?

#3

It would be best to create the mount as the user running the web front end. That is what I do for beta.rclone.org - that is run of an rclone mount fronted by Caddy.

Creating FUSE mounts as root isn't a good idea if you are doing that.

#4

Yes I'm running it as root... my full command is

rclone mount gdrive: /home/vod --allow-other --uid 1000 --umask 770 --log-file /root/log.txt --log-level INFO

Adding -vv didn't output anything to my terminal...except that clicking the folder in the web UI I see this:

2019/05/13 02:26:04 DEBUG : /: >ReadDirAll: item=2, err=<nil>

I can't su into my user because I think it was created without a login? Because it says Cannot execute /sbin/nologin: No such file or directory

However I can list the files there with sudo -u user ls /home/vod/ and can create too... sudo -u user touch /home/vod/test

#5

umask 770 basically breaks everything for you. You really want 002 I think.

The top blah is 770 and second is 002:

[felix@gemini ~]$ ls -al blah*
-------rw- 1 felix felix 0 May 12 23:22 blah
-rw-rw-r-- 1 felix felix 0 May 12 23:22 blah1
#6

Did not work with --umask 002 :frowning:

#7

Can you post the full actual command you used?

On the system, can you do a "ls -al" on the file?

#8

The same as the above, I just changed umask to 002...

The output of your command on a file inside the folder:

-rw-rw-r-- 1 user root 42534612 Feb 21 23:39 Smarters_V2.4.exe

#9

So that means everyone can 'read' that file on that list bit. You can always try 000 as well.

#10

It seems --allow-other are glitched on ubuntu 14.04 too

sudo -u user rclone mount gdrive: /home/user/vod --allow-other -vv
2019/05/14 18:28:42 DEBUG : rclone: Version "v1.47.0" starting with parameters ["rclone" "mount" "gdrive:" "/home/user/vod" "--allow-other" "-vv"]
2019/05/14 18:28:42 DEBUG : Using config file from "/home/user/.config/rclone/rclone.conf"
2019/05/14 18:28:42 DEBUG : Google drive root '': Mounting on "/home/user/vod"
2019/05/14 18:28:42 mount helper error: fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
2019/05/14 18:28:42 Fatal error: failed to mount FUSE fs: fusermount: exit status 1
cat /etc/fuse.conf
# Allow non-root users to specify the allow_other or allow_root mount options.
user_allow_other
#11

I think on that version you have to add the user to the fuse group:

addgroup <username> fuse

14.04 is end of life as of last month too.

You do need to log out/log back in for the group thing to work if that was the issue.

#12

My software only runs in 14.04. So this fixed my issue, but still can't read the files in the folder from the web interface :confused:

And I noticed that when I click on the folder in the interface I see this in my logs:

2019/05/14 18:47:57 DEBUG : /: >ReadDirAll: item=1, err=<nil>
2019/05/14 18:47:58 DEBUG : /: ReadDirAll:
2019/05/14 18:47:58 DEBUG : /: >ReadDirAll: item=1, err=<nil>

So it should be seeing the files right?

I'm using this now

sudo -u user rclone mount gdrive: /home/user/vod --allow-other --uid 1000 -vv

#13

If you made it that far, the only other thing I'd add is --umask 000 and that gives everything permissions.

#14

I think the issue is with the web interface...I ignored the UI to pick the file and wrote the complete file path to the file and it read the file without issues...

Thanks for the help!

#15

Woo! Happy it is working for ya.