File size problem

I am using rclone on a vps to serve as FTP and uplaod file to 1fichier.
The file size I am uploading is 100GB+ while the vps disk size is 50GB. I tried --vfs-cache-mode minimal , --vfs-cache-mode writes , --vfs-cache-mode full , in all cases first the file is being created on the vps then uploads to the 1fichier, which means VPS crashes due to the low space.
With cache: It wants to create a file as big as the file being uploaded >>>>>>>>>> VPS crashes, no space
Without cache: It creates the same size file in /tmp folder >>>>>>>> VPS crashes, no space

I played with the maximum cache size, did not help.

In short: Is there any way uploading file bigger than the rclone server disk size?

As per the docs @, 1fichier doesn't support streaming uploads, so unfortunately this won't be possible.

1 Like

Does it apply to remote to remote copy as well?

Yep, because there are no server-side copies (known as Copy in the feature table) in 1fichier which means rclone needs to download and upload the complete file.

1fichier was the best option for me, unfortunately we cant use it.
Thank you for your great help :slight_smile:

you could try
tho it has been in beta for a long time.

I don't think that will work. One of chunker's limitations is the need for server-side move or copy on the remote, neither of which is supported on 1fichier.

Chunker requires wrapped remote to support server side  `move`  (or  `copy`  +  `delete` ) operations, otherwise it will explicitly refuse to start.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.