FILE SIZE DIFFERENCE B2 web UI and local files

I have just finished my first complete sync. After a couple of issues (all of which were resolved thanks to this forum) I notice one thing.

If I check to the size of my files using rclone size my local files and the encrypted bucket are identical in both number of files and size. When I log on to B2 cloud the webui shows the total file size as bigger.

I thought this might be due to version but I used rclone cleanup and it is still the same.

LOCAL FILES Total Objects 56415 147.978 GBytes
RCLONE SIZE B2BUCKET is Total Objects 56415 147.978 GBytes
B2 Clone web UI Total Objects 56145 159.3 GB

Any ideas?

What happens if you use rclone size on the bucket underlying the crypt?

Oh, and try rclone size --b2-versions on it too

Ok so using rclone size [encrypted bucket] --b2-versions gives 56415 objects and total size 147.978GBytes.

The rclone size running on the unencrypted bucket gives 56415 files and 148.017 GBytes

Could it be the WEBUI is slow to catchup and isn’t showing the fact I deleted the old versions?

The number of objects is correct even down to the individual folders within the bucket.

I think it must be something like that - I can’t see where any files might be lurking!

I cant understand the difference between the encrypted set and the unencrypted set? Its only a small amount but I am guessing XXX:XXX will be the same as ENCRYPT: ?

I have two folders in my backup and I have compared the individual folders by the following methods

Using windows explorer Local matches the mounted version of encrypted bucket perfectly

and like I said, total objects matches perfectly between local, rclone and b2 web gui.

I have no idea. Maybe wait a couple of days and see. When I run RCLONE check it matches also.

Is this forum a suitable place for Linux based questions aswell? It is to help me get rclone running on a cron if its not already running.

There is a slight overhead to the encryption explained here.

I think your upload is good.

Probably a good idea.

Yes - make a new thread, or do a bit of searching - that question has come up before.

I understand the overhead point but my encrypted folder is smaller than my unencrypted folder?

I got the crontab to work. Thanks Could you point me to the DONATE PAGE? I saw it here somewhere but lost it

I’d expect the underlying remote for the crypt to be slightly larger than the crypt remote. So the encrypted data is slightly larger than the decrypted data.


The donate page is here

I think I get it now. The underlying bucket is the ENCRYPTED data. That’s why it is 148.017 GB

When I look at the bucket through the ENCRYPT remote then this is unencrypted so that’s why it is 147.978 GB

I was getting confused with the the underlying bucket being unencrypted when it is in fact encrypted. So the B2 WEB GUI should always be higher than the local data, just not the big difference I am seeing at the minute. The WEB GUI should match the 148.017GB.

Thanks very much. I am an ex crashplan customer so I am somewhat relieved I can use this now. I am running it on a READYNAS Duo V2 so had to increase the swap file but all is good.

Excellent work.

1 Like

I still had a difference in my WEB GUI and my rclone bucket so I contacted B2 Blaze.

The reply was that they use the byte count. It was only when I looked at rclone size result I think I see what they mean

The rclone size gives me 148.017 GB and in brackets gives 160221853204 Bytes: .

This is the 160.2 Gigabytes, or, 148.017Gibibytes as RCLONE does.

Gigabytes and gibibytes - Starting to get a little lost. but the Bytes add up, I think

The general gist I believe and having edited this post a million times is:

B2 Cloud Backup uses GIGABYTES 1GB = 1,000,000,000 Bytes

Everything else seems to use GIBIBYTES 1 GiB is 1024 x 1024 x 1024 =1,073,741,824 Bytes

Ah, ha! That makes sense - well done for persevering and working it out. Yes rclone uses binary MiB, GiB everywhere.