Fatal error: mount not ready

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

hi

For some reason, the videos that I have stored on my drive and that were mounted with rclone stopped working in Emby, the error started to appear:

I checked the assembly and everything seemed ok. So, to see if the problem would be fixed, I updated rclone as I was using version 1.56. I updated to the most current version (1.64.2).

However, after updating, the files "disappeared" from the folder where the assembly was located. So I'm trying to put it back together again to see if that's the problem and I can't. The error simply appears: Fatal error: mount not ready

Run the command 'rclone version' and share the full output of the command.

1.64.2

Which cloud storage system are you using? (eg Google Drive)

drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

mount

Paste command here

rclone mount : /mnt/*****/ --allow-other --daemon --dir-cache-time 9999h --vfs-cache-mode full --vfs-cache-max-size 200G &

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

Paste config here

A log from the command that you were trying to run with the -vv flag

Paste  log here

It is not good idea to run mount this way...

but for the start post results of:

rclone mount ****: /mnt/*****/**** --allow-other -vv

In addition post:

rclone version

and

rclone config redacted

2023/11/12 07:24:28 DEBUG : rclone: Version "v1.65.0-beta.7473.ad83ff769" starting with parameters ["rclone" "mount" ":" "/mnt/" "--allow-other" "-vv"]
2023/11/12 07:24:28 DEBUG : Creating backend with remote "********:"
2023/11/12 07:24:28 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2023/11/12 07:24:28 DEBUG : cineonline: Loaded invalid token from config file - ignoring
2023/11/12 07:24:28 DEBUG : Saving config "token" in section "
" of the config file
2023/11/12 07:24:28 DEBUG : cineonline: Saved new token in config file
2023/11/12 07:24:28 DEBUG : Google drive root '': Mounting on "/mnt/
***"
2023/11/12 07:24:28 Fatal error: failed to mount FUSE fs: fusermount: exec: "fusermount3": executable file not found in $PATH

Install fusermount3 - relate to your OS help

rclone v1.65.0-beta.7473.ad83ff769

  • os/version: debian 10.13 (64 bit)
  • os/kernel: 4.19.0-25-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.3
  • go/linking: static
  • go/tags: none

and

type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive = XXX
root_folder_id =

or consider updating your OS - I think the latest Debian 12 uses fuse3 by default.

thanks, it seems that the problem was exactly that, I installed fuse3 and this command worked fine:

rclone mount *: /mnt/ --allow-other -vv

Now a question, why isn't the command up there the right one? which one do you recommend for streaming?

Your command is ok and if it works for you do not change it.

What I only would change is the way how you run it:

rclone mount .... --daemon .... &

I see a lot of people reports problems with --daemon. The best way to run mount service (or any other service) on Linux is to use systemd.

Here some example:

It talks about onedrive remote but it does not matter - systemd part is the same for any remote.

BUT - if your way works for you... sometimes it is better not to change something good for better:)

I'm thinking about switching to systemd, as my mount stopped working out of nowhere, which bothered me with this problem. In addition, you also have to set a cron rule so that it does not disassemble on reboot. can you tell me if with systemd I need to add a cron task too?

No. You do not. Systemd can take care of all - restart on boot, restart if error etc.

You will find plenty of examples on Internet and this forum how to use and tune it.

Start simple and improve it as you learn.

gives an error when I put it

systemctl start rclonemount

and checking the errors below, I saw that it is something related to rclone config, but I already have a remote configured

systemd[1]: Starting RClone Media Mount Service...
rclone[19375]: NOTICE: Serving remote control on http://127.0.0.1:5575/
rclone[19375]: NOTICE: Config file "/opt/rclone/rclone.conf" not found - using defaults
rclone[19375]: Failed to create file system for "*****:": didn't find section in config file
systemd[1]: rclonemount.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: rclonemount.service: Failed with result 'exit-code'.
systemd[1]: Failed to start RClone Media Mount Service.

interesting. but my crystal ball does not work today. unless you provide more details nothing can be done:)

i solved the problem. it was just rclone.config that was in the wrong location

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.