Failed to configure token on lineageos14.1

Xiaomi Mi4w. Rclone on android nougat (lineageOS 14.1), installed using magisk, 0smosis busybox is installed as well. Using stock AOSP browser and ES File explorer Pro as well as terminal emulator from the playstore. Can get through installation process fine until it asks me to go to the 127.0.0.1..... web address (which it doesn't automatically redirect to my web browser). After typing in the address manually I go through the on screen process and it says successful, but after returning to terminal emulator I have the error Failed to configure token.

cancro:/ $ su
cancro:/ # rclone config
2019/07/06 15:36:32 NOTICE: Config file "/.rclone.conf" not found - using defaults
No remotes found - make a new one
n) New remote
s) Set configuration password
q) Quit config
n/s/q> n
name> googlenew
Type of storage to configure.
Enter a string value. Press Enter for the default ("").
Choose a number from below, or type in your own value
1 / A stackable unification remote, which can appear to merge the contents of several remotes
\ "union"
2 / Alias for a existing remote
\ "alias"
3 / Amazon Drive
\ "amazon cloud drive"
4 / Amazon S3 Compliant Storage Provider (AWS, Alibaba, Ceph, Digital Ocean, Dreamhost, IBM COS, Minio, etc)
\ "s3"
5 / Backblaze B2
\ "b2"
6 / Box
\ "box"
7 / Cache a remote
\ "cache"
8 / Dropbox
\ "dropbox"
9 / Encrypt/Decrypt a remote
\ "crypt"
10 / FTP Connection
\ "ftp"
11 / Google Cloud Storage (this is not Google Drive)
\ "google cloud storage"
12 / Google Drive
\ "drive"
13 / Hubic
\ "hubic"
14 / JottaCloud
\ "jottacloud"
15 / Koofr
\ "koofr"
16 / Local Disk
\ "local"
17 / Mega
\ "mega"
18 / Microsoft Azure Blob Storage
\ "azureblob"
19 / Microsoft OneDrive
\ "onedrive"
20 / OpenDrive
\ "opendrive"
21 / Openstack Swift (Rackspace Cloud Files, Memset Memstore, OVH)
\ "swift"
22 / Pcloud
\ "pcloud"
23 / QingCloud Object Storage
\ "qingstor"
24 / SSH/SFTP Connection
\ "sftp"
25 / Webdav
\ "webdav"
26 / Yandex Disk
\ "yandex"
27 / http Connection
\ "http"
Storage> 12
** See help for drive backend at: [link removed] **

Google Application Client Id
Setting your own is recommended.
See [link removed] for how to create your own.
If you leave this blank, it will use an internal key which is low performance.
Enter a string value. Press Enter for the default ("").
client_id>
Google Application Client Secret
Setting your own is recommended.
Enter a string value. Press Enter for the default ("").
client_secret>
Scope that rclone should use when requesting access from drive.
Enter a string value. Press Enter for the default ("").
Choose a number from below, or type in your own value
1 / Full access all files, excluding Application Data Folder.
\ "drive"
2 / Read-only access to file metadata and file contents.
\ "drive.readonly"
/ Access to files created by rclone only.
3 | These are visible in the drive website.
| File authorization is revoked when the user deauthorizes the app.
\ "drive.file"
/ Allows read and write access to the Application Data folder.
4 | This is not visible in the drive website.
\ "drive.appfolder"
/ Allows read-only access to file metadata but
5 | does not allow any access to read or download file content.
\ "drive.metadata.readonly"
scope> 1
ID of the root folder
Leave blank normally.
Fill in to access "Computers" folders. (see docs).
Enter a string value. Press Enter for the default ("").
root_folder_id>
Service Account Credentials JSON file path
Leave blank normally.
Needed only if you want use SA instead of interactive login.
Enter a string value. Press Enter for the default ("").
service_account_file>
Edit advanced config? (y/n)
y) Yes
n) No
y/n> n
Remote config
Use auto config?

  • Say Y if not sure
  • Say N if you are working on a remote or headless machine
    y) Yes
    n) No
    y/n> y
    If your browser doesn't open automatically go to the following link: htt p://127.0.0.1:53682/auth
    Log in and authorize rclone for access
    Waiting for code...
    Got code
    2019/07/06 15:39:02 Failed to configure token: failed to get token: Post https://accounts.google.com/o/oauth2/token: dial tcp: lookup accounts.google.com on [::1]:53: read udp [::1]:44031->[::1]:53: read: connection refused
    1|cancro:/ #

Any help appreciated apologies if it's a noob question, thank you.

Run as a headless setup and use a browser and paste in the token.

No sorry still getting the same error. What is the error actually implying? I had a hosts file adblocker installed (energized protection from magisk) but it still didn't work even after disabling it

If you pick headless and enter the URL into a working browser, you get a key. You can use the same browser you are posting here.

The error is saying whatever you are using can't connect out to the Interrnet.

I done this and I'm still getting the same error, after pasting the verification key into my phones terminal (which I got from my desktop web browser) it shows up with the same error as I got previously.

How do you get the same error if you pick headless and get a code from the browser? That doesn't make sense as it's a different path. Can you post a screenshot of what you are doing.

That means your machine after you enter the token can't get out to the Internet.

Are there no immediate solutions then? Thanks for taking the time to help anyway I appreciate it

It's not really a rclone thing to fix. I'm not familiar with Android nor what OS you are on other than it doesn't seem to get out to the Internet. You'd have to troubleshoot that and get that resolved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.