Error when trying to copy from Windows mapped drive to Google Drive


I am trying to copy over some folders on a shared mapped drive up to Google Drive. These files are housed on a server in our enviroment and we are working to get rid of the mapped local drives. This is my command:

rclone copy "\SERVERNAME\Finance-Copy\Finance & Accounting\General Ledger" General Ledger:GeneralLedger

I am getting this error
Command copy needs 2 arguments mininum
The system cannot find the path specified.

What is your rclone version (output from rclone version)

C:>rclone version
rclone v1.41

  • os/arch: windows/amd64
  • go version: go1.10

Windows 7 64bit

Using Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy "\\pprsvr1\Finance-Copy\Finance & Accounting\General Ledger" General Ledger:GeneralLedger

The rclone config contents with secrets removed.

[General Ledger]
type = drive
client_id =
client_secret =
scope = drive
root_folder_id = XXX
service_account_file =
token = {"access_token":"XXX","token_type":"Bearer","refresh_token":"XXX","expiry":"2020-06-25T12:10:32.3423966-05:00"}

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

  • you need to update your rclone. your version is over two years old.

  • if your source or dest has a space character, then you need to quote it.
    "General Ledger:GeneralLedger"

  • run your command with flag -vv for debug output and post the output

1 Like


I updated my RClone to current version. Thanks for that recommendation. I also quoted my destination and it seems to be working. I appreciate the quick assistance. This is an excellent tool. Props to all that contribute to it. :slight_smile:

1 Like

sure, glad to help

you can also contribute and i assure you that i do not profit financially from donations.

1 Like

given how old your rclone version was,
make sure you are using the lastest winfsp.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.