Error reading source directory "...": directory not found


#1

I’ve been getting an error with rclone sync being unable to access certain directories. The log report is as follows:

2018/12/27 16:31:19 INFO  : Starting bandwidth limiter at 15MBytes/s
2018/12/27 16:31:19 DEBUG : rclone: Version "v1.36" starting with parameters ["/usr/sbin/rclone" "sync" "/media/london" "gdrive-crypt:" "--exclude-from" "/home/rclone/rclone_exclude" "--log-level" "DEBUG" "--log-file" "/media/london/Incoming/Notes/rclone.log" "--bwlimit" "09:00,15M 00:00,off"]
2018/12/27 16:31:21 INFO  : Encrypted Google drive root 'Backup': Modify window is 1ms
2018/12/27 16:31:21 DEBUG : Google drive root 'Backup': Reading ""
2018/12/27 16:31:21 DEBUG : Google drive root 'Backup': Finished reading ""

<…all the file check messages…>

2018/12/27 18:07:56 INFO  : Encrypted Google drive root 'Backup': Waiting for transfers to finish
2018/12/27 18:07:56 ERROR : Encrypted Google drive root 'Backup': not deleting files as there were IO errors
2018/12/27 18:07:56 ERROR : Attempt 1/3 failed with 0 errors and: error reading source directory "Music/Hip-Hop & Rap/Beyoncé/LEMONADE": directory not found
2018/12/27 18:07:56 DEBUG : Google drive root 'Backup': Reading ""
2018/12/27 18:07:56 DEBUG : Google drive root 'Backup': Finished reading ""

…And then it restarts. The weird thing is, the user running the script can access this directory and its files just fine. Here’s the file permissions for the ‘Beyonce’ directory (don’t hate), the ‘LEMONADE’ directory (the one that breaks rclone), and another directory that works fine:

rclone@rclone:/media/london/Music/Hip-Hop & Rap/Beyoncé$ ls -l
total 0
drwxr-xr-x 2 rclone root 0 Dec 15 23:13 4
drwxr-xr-x 2 rclone root 0 Dec 15 23:13 B'Day
drwxr-xr-x 2 rclone root 0 Dec 15 23:13 Beyonce
drwxr-xr-x 2 rclone root 0 Dec 15 23:13 Dangerously In Love
drwxr-xr-x 2 rclone root 0 Dec 15 23:13 I Am... Sasha Fierce
drwxr-xr-x 2 rclone root 0 Dec 15 23:13 LEMONADE
rclone@rclone:/media/london/Music/Hip-Hop & Rap/Beyoncé$ cd LEMONADE/
rclone@rclone:/media/london/Music/Hip-Hop & Rap/Beyoncé/LEMONADE$ ls -l
total 88064
-rwxr-xr-x 1 rclone root  5984746 Apr 25  2016 01 PRAY YOU CATCH ME.mp3
-rwxr-xr-x 1 rclone root  6723419 Apr 25  2016 02 HOLD UP.mp3
-rwxr-xr-x 1 rclone root  8440993 Apr 25  2016 03 DON'T HURT YOURSELF (feat. Jack White).mp3
-rwxr-xr-x 1 rclone root  7495178 Apr 25  2016 04 SORRY.mp3
-rwxr-xr-x 1 rclone root  8560181 Apr 25  2016 05 6 INCH (feat. The Weeknd).mp3
-rwxr-xr-x 1 rclone root  9496672 Apr 25  2016 06 DADDY LESSONS.mp3
-rwxr-xr-x 1 rclone root  7365769 Apr 25  2016 07 LOVE DROUGHT.mp3
-rwxr-xr-x 1 rclone root  5305023 Apr 25  2016 08 SANDCASTLES.mp3
-rwxr-xr-x 1 rclone root  2289589 Apr 25  2016 09 FORWARD (feat. James Blake).mp3
-rwxr-xr-x 1 rclone root  9708484 Apr 25  2016 10 FREEDOM (feat. Kendrick Lamar).mp3
-rwxr-xr-x 1 rclone root 10089242 Apr 25  2016 11 ALL NIGHT.mp3
-rwxr-xr-x 1 rclone root  7010066 Apr 25  2016 12 FORMATION.mp3
rclone@rclone:/media/london/Music/Hip-Hop & Rap/Beyoncé/LEMONADE$ cd ../4
rclone@rclone:/media/london/Music/Hip-Hop & Rap/Beyoncé/4$ ls -l
total 86016
-rwxr-xr-x 1 rclone root 8326205 Apr 18  2014 01 - 1+1.mp3
-rwxr-xr-x 1 rclone root 7279402 Apr 18  2014 02 - I Care.mp3
-rwxr-xr-x 1 rclone root 4861969 Apr 18  2014 03 - I Miss You.mp3
-rwxr-xr-x 1 rclone root 7982805 Apr 18  2014 04 - Best Thing I Never Had.mp3
-rwxr-xr-x 1 rclone root 8011122 Apr 18  2014 05 - Party Ft. Andre 3000 And Kanye West.mp3
-rwxr-xr-x 1 rclone root 6426685 Apr 18  2014 06 - Rather Die Young.mp3
-rwxr-xr-x 1 rclone root 5930682 Apr 18  2014 07 - Start Over.mp3
-rwxr-xr-x 1 rclone root 8192334 Apr 18  2014 08 - Love On Top.mp3
-rwxr-xr-x 1 rclone root 6371619 Apr 18  2014 09 - Countdown.mp3
-rwxr-xr-x 1 rclone root 7294179 Apr 18  2014 10 - End Of Time.mp3
-rwxr-xr-x 1 rclone root 7449874 Apr 18  2014 11 - I Was Here.mp3
-rwxr-xr-x 1 rclone root 8064123 Apr 18  2014 12 - Run The World (Girls).mp3

I also tried an rclone -vv lsf on the directory, here’s what I get:

rclone@rclone:~$ rclone -vv lsf /media/london/Music/Hip-Hop\ \&\ Rap/Beyoncé/LEMONADE/
2018/12/27 19:59:52 DEBUG : rclone: Version "v1.45" starting with parameters ["rclone" "-vv" "lsf" "/media/london/Music/Hip-Hop & Rap/Beyoncé/LEMONADE/"]
2018/12/27 19:59:52 DEBUG : Using config file from "/home/rclone/.config/rclone/rclone.conf"
01 PRAY YOU CATCH ME.mp3
02 HOLD UP.mp3
03 DON'T HURT YOURSELF (feat. Jack White).mp3
04 SORRY.mp3
05 6 INCH (feat. The Weeknd).mp3
06 DADDY LESSONS.mp3
07 LOVE DROUGHT.mp3
08 SANDCASTLES.mp3
09 FORWARD (feat. James Blake).mp3
10 FREEDOM (feat. Kendrick Lamar).mp3
11 ALL NIGHT.mp3
12 FORMATION.mp3
2018/12/27 19:59:52 DEBUG : 2 go routines active
2018/12/27 19:59:52 DEBUG : rclone: Version "v1.45" finishing with parameters ["rclone" "-vv" "lsf" "/media/london/Music/Hip-Hop & Rap/Beyoncé/LEMONADE/"]

The even stranger thing is that I struggled with this error with another directory a while ago (another music album by another artist). At that time, there were no errors in the Beyonce directory. I decided to try to solve the issue by deleting the folder generating the errors. Obviously, I stopped getting errors on the folder I deleted, but instead started getting errors on the Beyonce folder. Any help fixing this would be appreciated!


#2

I’m guessing it’s because of the e in the Beyonce with the accent.

I usually try to make sure I don’t have & or special characters in filenames or spaces for that matter as it just creates problems.


#3

It backs up all the other albums in that directory. I have lots of folders with accents that it handles just fine.


#4

When you fixed it before, did you recreate the same folder / directory name?


#5

No, I just left the album deleted. I’ll try to move the folder at issue off the volume and back on to see if that fixes it.

EDIT: I moved the Beyonce folder off the volume and have restarted rclone to see if the issue goes away or just move to another folder. It’ll take a bit to finish rescanning, but I’ll report back soon.


#6

Quick update. I moved the Beyoncé folder off the volume and rclone finished successfully. I moved it back in and it failed in the same place. I moved the folder it was erroring out on (LEMONADE) out and it failed on a different Beyoncé album. The other failure I mentioned in the OP was on a György Ligeti album (also special character in the name). I do have other artists with special characters in their names (Gabriel Fauré and others) that back up just fine. I’m going to try to change to folder name to just Beyonce and see if that works…

quick edit: I just changed the Beyoncé folder name… When I put the cursor at the end of the folder name and hit backspace, instead of deleting the é, it just changed it to an unaccented e… maybe the é I had in the folder name was some weird representation of the e accent that was tripping up rclone?


#7

I did some testing and was able to copy with the Beyoncé as well.

I wonder if there was some other character in there that was causing an issue.


#8

That very well could be. I copied in a normal accent e to see if that fixed it. If not, I’ll just drop the accent and call it a day. I realized too late that I should have copied the weird accent e character out of the file name to take a closer look at what it actually was…

edit: That fixed it! Beyoncé folder is now transfering. It turns out the accented e character I had in the file name originally was weird somehow.


#9

I note you are using an old version of rclone - we did a lot of work in character normalization in 1.38 which is probably the problem here… I’d recommend the latest release of course :wink:


#10

Thanks. I completely missed the old version in the logs.