Error "Entry doesn't belong to directory" on Raspbian

When I run the following command on my raspberry pi running raspbian:
rclone -v sync Dropbox:/ /mnt/ssd/data/Dropbox

I get a lot of the following errors :
2017/09/30 05:00:36 ERROR : photos/Ete 2015/P1060139.JPG: Entry doesn't belong in directory "Photos/Ete 2015" (too short) - ignoring

Notice that the remote file starts with a lower case ‘p’ on photos while the local one starts with an upper case ‘P’
But when I look on, I can an upper case ‘P’ as on my local file.

Another kind of the same error:
2017/09/30 05:00:36 ERROR : musique/Accords & Gammes/15-Guitar_Tabs_dup.pdf: Entry doesn't belong in directory "Musique/Accords & Gammes" (too short) - ignoring
with an upper and a lower ‘m’ on ‘Musique’

And this one:
2017/09/30 05:00:37 ERROR : Atelier Impro/morceaux/Eric Barret/Baby Cry: Entry doesn't belong in directory "Atelier Impro/Morceaux/Eric Barret" (too short) - ignoring
where the problem is not at the start of the name but in a subdirectory named ‘morceaux’ with an upper or a lower ‘m’

Another one:
2017/09/30 05:00:37 ERROR : Bande à GALA/cd/Master/01 - Loukoumotive.wav: Entry doesn't belong in directory "Bande à GALA/CD/Master" (too short) - ignoring
I’m using the official dropbox client on an Ubuntu laptop and on PCs where I have no such problem…

Any idea?

I’m pretty sure this got fixed in 1.38 - try that (was released yesterday!)

Great, thanks!

1 Like