Error during copy on two onedrive remotes


#1

Hi,
I’m trying to move some files from a remote to another running this:

rclone copy remote1: remote2: -P

Both remotes are Onedrive for business accounts. The problem is that when file transfer progress reach something near to 50% the copy process fails and all uploads restarts from the beginning (0%). Also in this new upload session the same error occurs in the same conditions. The log reports this errors the moment that copy process fails:

log:
https://pastebin.com/raw/Gjcm0gf9

rclone config:

[remote1]
type = onedrive
token = {“access_token”:""}
drive_id = XXX
drive_type = business

[remote2]
type = onedrive
token = {“access_token”:":""}
drive_id = XXX
drive_type = business
client_id = XXX
client_secret = XXX

rclone version:
rclone v1.45

  • os/arch: windows/386
  • go version: go1.11

#2

I see these errors in your log, the first from the source and the second from the destination

  • wsarecv: An existing connection was forcibly closed by the remote host
  • i/o timeout

What it looks like is your internet connection had a wobble there and closed all the connections. Could there be a firewall in the way which doesn’t like long running connections? Maybe your ISP?

I guess it could be onedrive deciding it has had enough too.

How consistent is the problem?


#3

I tried running the copy using same source (onedrive) and a different destination (a gdrive remote). I see that the same i/o timeout errors occurs (but not wsarecv).

log:
https://pastebin.com/raw/Qif39QAa

I tried also to copy the same folder from local to gdrive and onedrive using this command:

rclone copy X:\folder remote:folder -P

In this case everything went fine. No errors or problems during upload.

Do you think this may be due to ISP limitations? If so, I can investigate following this way.


#4

I think something to do with your upload path. So it could be your home router needs new firmware or your ISP throttling.