Encryption form CRYPT to ENCFS

Is there an easy way change the encryption of my cloud stored files form the builtin CRYPT to ENCFS without the need of storing them locally and rather reencrypt them on the fly?

I tried already using rclone copy to copy files from the cloud to a mounted ENCFS folder from the cloud with gave out a lot of errer wirting all files but leaving them at 0kb file size. Think the error was input/output error.

Best regards,

i am not sure what your issue is. is it transferring all the data or storing it?
you always have to transfer the data to some local storage or at least RAM to re-encrypt it.

Please give some more details of your setup and the error message you received.

What are you using for the mount? I think rclone mount doesn’t play nice with encfs on top of it, at least for writes.

encfs has --reverse, it mounts a folder, for ex the already mounted crypt folder, in an ecrypted way. - I did not try this yet, I mean to copy this way…
What I did try is to mount my FTP, decrypt it using encfsmp, encrypt the decrypted folder using encfs --reverse and decrypt that with the second encfs.xml :smiley:

So what you could do is, use encfs --reverse and rclone copy the encfs-encrypted folder.

!!!Save the encfs.xml!!! WIth rclone crypt you only need the passwords, with encfs you also need the xml.

alright sorry guys. i am having a vps and looking to encrypt my files with encfs. What i did was create a folder in the cloud. On VPS use a FUSE mount system for that cloud. Enabling ENCFS from that folder. Then I tried using rclone copy to copy files to that folder. Returning in an error

So you think mounting the rclone folder then enable encfs reverse and copy with rclone files to the cloud from the encrypted encfs folder? Sounds good. Ill give it a shot…

yes, that sounds good. still the mount could be an issue.
who is your cloud provider?