Emby library path disappears due to RClone permissions

Hello guys, i really tried to find this answer in this forum, forgive me if this is a repost. I installed Rclone v1.51.0 on a Ubuntu 18.04.03 (x64) LTS on VPS with an Emby Server

I´m using RClone for mounting Google Drive.

I created an user "rclone" (added to "root" group) with a folder "GDrive" for the mounting. I ran the mounting as rclone using the command below

nohup rclone mount GDrive: /home/rclone/GDrive --allow-non-empty &

It mounted normally and I can navigate through its files when i´m on VPS but when I´m using Emby, i try to search for the files and the maximum I can get is /home/rclone (after that the path disappears!)

My folders on GDrive mounting have the following permissions:

drwxrwxr-x 1 rclone rclone 0 Feb 26 00:04 TEST_EMBY

Considering Emby runs a service account with the same name "emby" I believe it doesn´t have enough permissions to view these files. I tried everything to resolve this but unfortunatelly it doesn´t work.

PS: It really seems something with RClone because when i unmount it and create a new folder under GDrive with rclone:rclone it can normally be seen in the emby browser

Does anybody have an idea? Thank you in advance

You just need to add --allow-other to the mount command. Fuse in general only lets the user read that is executing the process so you have allow other folks to read it.

1 Like

@Animosity022 Thank you for your reply.

I will try that. Do you recommend me to mount as rclone user or root? Can I use nohup?

I tend to not run things as root unless you have to so a user is just fine as mine runs as a user.

If you want to start it manually, you can just tag --daemon on the end of it and that works fine and remove the nohup. That makes the process run as a daemon in the background once you hit enter. It'll still be there until you stop it or reboot.

You can use a service file as well but that requires a bit more to setup but that can start on boot.

Mine looks like:

Thank you so much for your help, it worked.

But now i´m only having problems to use --daemon...it says i cannot use more than 3 arguments

This is the line i´m using

nohup rclone mount GDrive : /home/rclone/GDrive --allow-other --allow-non-empty &

How can I use it with --daemon?

I'd remove non-empty as well as you want the directory to be empty before you mount it so you don't over mount so I'd use something like:

rclone mount GDrive : /home/rclone/GDrive --allow-other -dir-cache-time 1000h --daemon

and to stop it

fusermount -uz /home/rclone/GDrive

Thank you for your hints my friend, it really helped me a lot :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.