Edu business dropbox error? Update: API v1 endpoints are turned off 9/28

I have dropbox business through my employer and I was able to create a new remote for backup. However, the rclone commands returns:

$ rclone copy crypttest/ dropbox:
2017/09/29 20:18:24 Attempt 1/3 failed with 1 errors and: v1_retired
2017/09/29 20:18:24 Attempt 2/3 failed with 1 errors and: v1_retired
2017/09/29 20:18:25 Attempt 3/3 failed with 1 errors and: v1_retired
2017/09/29 20:18:25 Failed to copy: v1_retired

Doesn’t seem to be an rclone issue since it works with my main gdrive remote. We have an authentication page redirect before logging in dropbox, not sure if that’s causing the error.

I’m getting the same behavior. I’ve used rclone with Dropbox for months with very similar files (dozens of them), and this is the first instance of that kind of failure. I thought perhaps the issue might be file size, but I got the same message for an empty file. I can upload the same files through the Dropbox web interface.

Addendum: I get the same error message with an ‘ls’ command:

Failed to ls: couldn’t list: v1_retired

But if I enter the same ‘ls’ command from another machine (using the same .conf file) it runs OK.

I don’t know what “v1_retired” means, can’t find any web traffic on it.

yup no go with ls for me as well.

update: it seems like this is due to the deprecated API as of yesterday 9/28


June 28, 2016: API v1 is deprecated.

September 28, 2016: If you haven’t acknowledged the deprecation, new users of your app will see a warning when linking their Dropbox account.

June 28, 2017: If you haven’t acknowledged the deprecation, all users who have linked their Dropbox account to your app will receive a warning email.

September 28, 2017: API v1 endpoints are turned off.

Thanks for your patience and understanding in the transition to our new API v2. We’re continually working to improve your experience developing for the Dropbox Platform.

Dropbox no longer usable, switching to Google Drive.

Update your rclone to 1.37 or 1.38 which supports the dropbox v2 API and all will be well :slight_smile:


+1. Just upgraded to the latest version and everything worked fine. In fact, worked better than before, as API 2 allows a better file checking system.

1 Like