Dropbox - no "members.read"

I think it would be worth rebuilding the remote without impersonate and see if that works.

You don't need it unless you are a team admin I think.

Ah... on the remote-headless box I did but not on my local-gui box I did not update to that latest dev 'rclone' version.
Now with that dev rclone on local-gui box "reconnect" got me a "Success!"
I'll have to do again with a clean sheet if I want to chip in to that "howto" I mentioned.

A question - again I'm a novice to both "rclone" & Dropbox so bare with me if this is made clear somewhere in Rclone's docs - is Rclone portable in terms of configs/remotes/setup?
Reason I ask is such that now having apparently, after "reconnect", my local-gui box shows no errors for:
-> $ rclone ls us-full: --config /etc/rclone/dropbox.conf --verbose
1467194 Getting Started with Dropbox.pdf

But having that same config/setup on a second remote-headless box "ls" still fails with:

2021/02/13 11:36:34 ERROR : : error listing: missing_scope/.

What have I missed? I though I read somewhere that once a "rclone" got connected, set up to a remote then by the means of just config files "multiple" rclones on different computers can work with the same remote.

many! thanks, L.

ps. If it's you who manages packages for distros then I'd dare to suggest - push it downstream (I myself am Fedora user)

Best to use no package manager and download from rclone directly as that's the best and recommended way to install it as package managers can do whatever they want and are not maintained by rclone.

Yes it should be - the config file is portable to any OS.

Have you got the same rclone version in both places?

Oh.. I just realized that the "reconnect" actually does something to the "config". Now with that "new" config also on remote-headless box "ls" does work too.

Nice work, honestly many thanks for quickly responding to the problem.
I'll keep my fingers crossed for you devel guys not to let Dropbox changing(braking) stuff slip through behind your back without notice in the future.


We did some of the changes in advance for the dropbox change, but this one slipped through the net! That is what point releases are for though.

I guess first question is - is it even possible to have "rclone" work with "App Folder" ?

hello and welcome to the forum,

have you tried this?
"Choose the type of access you want to use => Full Dropbox or App Folder"

have you tried the beta that was mentioned up above in this topic.

Thanks, i will try it

as mentioned in another thread on the very same subject rclone not accessing the shared folders with Teams on Dropbox business / [Dropbox Business not accepting oauth2]
Well so far not much luck even with the forked version:
$ rclone version
rclone v1.55.0-beta.5175.aee3bfb17.fix-dropbox-scopes

  • os/arch: linux/arm
  • go version: go1.16rc1

I access my personal folder but not the Teams shared folder....
still the same error all the time:
$ rclone lsd dpbx:/
2021/04/09 22:16:30 Failed to create file system for "dpbx:/": get current account failed: missing_scope/.


$ rclone --dropbox-impersonate rxxxxxxxxxxxx lsd dpbx:/
2021/04/09 22:17:16 Failed to create file system for "dpbx:/": invalid dropbox team member: "xxxxxxxxxxxxx": missing_scope/.

sadly...... :frowning:

any further ideas?

You need to do the rclone config again with impersonate set. Can you try that?

:slight_smile: I did, .... but :frowning: at the of the process we end up in a Dropbox page error 400!!! - each time I try tp use impersonate for the config creating a new remote connection...

Same issue!
Ive tried every possible fixed in this thread...no dice!

Saddly, rclone is no longer working with Dropbox business. So bad...
And the issue is clearly coming from Dropbox themselves.
Shame on them...
Finally I have use Multcloud and setup an FTP on my NAS-Rpi . Multcloud does work very well with DropBox business Teams folders. So I use Multcloud for accessing Dropbox business and then backup all my Team folders to my NAS-Rpi via SFTP (SHH ftp actually). I did not want to do that as I have now to watch and protect some ports on my Rpi-NAS and on my router... but this is life...

Hi guys.
Recent additions to this thread - which I originated - looked alarming enough that I checked and can confirm: Dropbox business with rclone I use, ver. rclone-1.55.0.beta.5215.4b5fe3ada-1.x86_64 still work, all good since I set it up.
I cannot comment on "Teams" nor "sharing folders" - I don't use don't need it - but should one boil it all down to: rclone + dropbox(business) - I say all good.

I think the problem is with the impersonate flag?

If you aren't using that then it should work fine.

Does everyone agree with that?

One problem with me testing this is that I don't have access to a dropbox business account.

No, not for me, no 'impersonate' in my configs, which configs are rather simple.

This bit I use as args to 'rclone'
--dir-perms 0700
--file-perms 0600
--umask 0077
--dir-cache-time 168h
--timeout 1h
--vfs-cache-mode writes
--vfs-read-chunk-size 256M
--vfs-read-chunk-size-limit 2048M
--tpslimit 10"

and a config example, in its entirety:

type = dropbox
client_id =
client_secret =
token =

This works on both CentOS Stream and Fedora 33/34.
Now, snapshots of my Dropbox App's "Permissions" (being restrictive as I want it I need it)

1 Like

I propose - use those as a minimal starting base.
Obviously, rclone's setup steps will be important, connection, tokens, etc. but that above should work and if it does for you guys then later continue tweaking from there.

1 Like

I have this working since earlier, but when I just tried to setup a new app with the same app-settings, it did not work.
If I ran the config without the --dropbox-impersonate the App only gets added to my user-account, when I run it with the --dropbox-impersonate flag, I get an error as follows, and the app does not get added.

HOWEVER, when I in that Dropbox error URL manually add "+team_data.member" in the string of requested scopes it works!!!

So there is probably just this extra scope-section missing in the rclone URL generation for dropbox config.
version used that has this error:
D:\bin>rclone -V
rclone v1.55.0-beta.5334.ac7acb9f0.fix-dropbox-batch-sync

  • os/type: windows
  • os/arch: 386
  • go/version: go1.16.3
  • go/linking: dynamic
  • go/tags: cmount

same behaviour on this below version:
rclone v1.55.0

  • os/type: windows
  • os/arch: amd64
  • go/version: go1.16.2
  • go/linking: dynamic
  • go/tags: cmount

I just posted this in the other thread which hopefully will fix the problem if you do a rclone config reconnect with an impersonate email set. Can you give it a try?

v1.56.0-beta.5409.9b054c0cd.fix-dropbox-impersonate-scopes on branch fix-dropbox-impersonate-scopes (uploaded in 15-30 mins)