Dropbox mount - new files doesn't show up in mounted folder

I my new to rclone. I installed rclone on a raspberry pi 4 (linux), got it setup with mounting my dropbox into ~/Dropbox and it almost works.

What is the problem you are having with rclone?

Files created on other locations than the RPi doesn't show up in the mounted folder (they do show up on dropbox.com). Changes to existing files seems to show up just fine. Also files created in the mounted folder gets created on other clients.

Run the command 'rclone version' and share the full output of the command.

atte@strandby:~$ rclone version
rclone v1.53.3-DEV
- os/arch: linux/arm64
- go version: go1.15.9'''

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount 'dropbox atte:' ~/Dropbox/ -vv --log-file=/home/atte/rclone.log

The rclone config contents with secrets removed.

atte@strandby:~$ cat .config/rclone/rclone.conf 
[dropbox atte]
type = dropbox
client_id = SECRET
client_secret = SECRET
token = {"access_token":"sl.BXzYclwK56zPPhTkJ2x3IrS_WcTtwGhK5sEczUjhLSjufnVZBY41Mthg0RvkD4s8gNBE6zA7jMsEmAfmjqY56LoEWQIFrljTvozeZawFEXxHzthc0anImHjQL-tA03scCVuZGi-A","token_type":"bearer","expiry":"2023-01-29T16:07:27.390384521+01:00"}

A log from the command with the -vv flag


That’s a very man years old. Update from the install page and test again.

Thanks, updating to latest seems to have solved the problem.

Additional question: I had to authorize again, was that due to a new version of rclone being used or had my config_token expired? If the later, how do I avoid having to re-authorize every few hours?

Again: thanks so much to the help so far!

Not that I'm aware of as I use dropbox.

Did you edit the config file? If it's expiring, you've made a process issue somewhere.

Rclone's config as user specific so it you change it, make sure it's on the same user.
Don't manually edit the files, use the rclone config as that removes a lot of error.

When you authorize, you want to make sure you see your API app name come up and not rclone.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.