Dropbox expired_access_token

Just go through the config for dropbox again?

Set the redirect_url

Run rclone config reconnect yourremote:

Do not cut and paste any tokens - this should all be automatic.

Did that now.
Gonna test it and get back to you.

If the redirect URI wasn't set, the authorizing of the remote wouldn't have worked so you were using the default rclone client ID/secret.

I thought I set that in the beginning, but I might have done that at another app I made at one point.

I realized it didn't work because I didn't update it.
I've set it to run for 25 hours now.

I don't know if I'll write here the day of New Years, if not, I'll get back one of the days after that.

Thank you so far :slight_smile:

I just decided to check in on it, and the log says this today:

2022/12/30 11:17:19 DEBUG : dropbox: Token refresh failed try 1/5: oauth2: cannot fetch token: 400 Bad Request
Response: {"error": "invalid_grant", "error_description": "refresh token is invalid or revoked"}

This is my current dropbox config:

type = dropbox
token = {"access_token":"XYZ","token_type":"bearer","refresh_token":"XYZ","expiry":"2022-12-30T03:09:07.6166355+01:00"}
client_id = XYZ
client_secret = XYZ

And my App settings:

After you fixed your URI in your app, did you reconnect it?

Specifically, what steps did you do after fixing the redirect URI?

I might have done it wrong. I had trouble setting it up in the first place since it's running headless.

Here's the steps I've done:
rclone config reconnect dropbox:
in the terminal of the server.

At the "Already have a token - refresh?" I seleted "yes".

At the "Use web browser to automatically authenticate rclone with remote?"
I selected no, becasue of this text:
"Use web browser to automatically authenticate rclone with remote?

  • Say Y if the machine running rclone has a web browser you can use
  • Say N if running rclone on a (remote) machine without web browser access
    If not sure try Y. If Y failed, try N."

This is where I had trouble the first time.

How I fixed it, was by downloading rclone on my desktop (Wwindows 11), extract it, open cmd int he directory, and use "rclone authorize dropbox"

Copy the token

And pasted it into the terminal.

I'm not even sure that's the config token.

Here's a picture of it all from the terminal:

You still have something wrong along the way as that's using the rclone API still as it has the rclone logo and rclone info there.

Your app should show up.


rclone.conf are portable / pastable so you can create it on any machine and just copy it or paste it over.

I'd just use whatever machine you have a browser on and make a new dropbox remote and just copy/paste that into your rclone.conf

Looks like I'll need to install a VM, set it up there, and copy the config over then.

I'll try that, and get back to you :slight_smile:

Why? Just use the machine you are posting this on as all you need is a browser.

It doesn't save anything in the folder I'm using it from on Windows, so I have no config file.
It's not in %appdata% either.

It creates it once you complete and finish your rclone.conf.

Many folks use Windows.

It showed up with the correct name on the API now!

I've added the config to the server now.

Guess I'm back to testing :slight_smile:

Thank you again.
And your patience!

I use development for my 2 app ids on dropbox and never have had an issue.

Did you read through the thread as that wasn't the issue?

Looks like it renewed itself now.

I still fail to see where the problem was at though....

Was it because I didn't authenticate with the app API, and I needed to add the "http://localhost:53682/" to the app as well?

When you created your own client ID/secret, you never connected it.

If you tried to connect it, it would have failed because the redirect URI wasn't there.

Without meticulously going through all your steps, some things will be a mystery as you've missed something somewhere along the way.