--drive-v2-download-min-size not working as intended

--drive-v2-download-min-size is not working above 1.39.

I've tested using 1.39 and getting 6Gbit speed transfers steadily.

However using the latest version and
, I intermittent 1Gbit >0mb/s>1Gbit and so on.

It's not working as it should. Please help as I need --max-transfer which is not present in 1.39.

Can you share all the stuff in the question template?

Version, Debug Log, etc.

1.50.1 @1Gb/s slow speeds

DEBUG : pacer: Reducing sleep to 192.959697ms                                                  
2019/11/11 01:25:36 
DEBUG : pacer: Reducing sleep to 215.471669ms      

1.39 @6Gb/s Steady speeds
DEBUG : test.dmg: Sending chunk 2566914048 length 8388608

pacer reducing sleep is the one that's causing 1Gbps>0Mbps>1Gbps>0Mbps.

Missing the command you are running and the full log.

You get a pacer message when you do too many API hits per second as that's a normal message.

I don't get it on 1.39.

Again, the subject is v2. Seems like v2 command is not working at all on newer rclone versions. I've tried 1.44 to 1.50.1. All have the same issue.

It's definitely not using v2. I'm getting steady transfers on 1.39.

Edit: Also the pacer message doesn't happen at all on 1.39. That's the only difference between the 2. And yes, I've double checked the logs.

1.39 is ancient and doesn't have any pacer code so you would not see it there.

If you want some help, the command and the full debug log is needed.

Are you doubting my claim, I hope you can trust my word on it. 6Gb/s speeds transfer vs 1Gb/s is a big difference. And I know for a fact the v2 command is not working. Hope @ncw or someone can shine a light here.

Huh? No one is doubting your claim.

I can't figure out what you are running since you aren't sharing a log or a command so I can't trouble shoot or replicate the issue.

It has nothing to do with trust. I'm trying to help you and I don't have information to help you.

on 1.39

rclone copy -v gdrive1:test1 gdrive2:test2

on 1.44-1.50.1

rclone copy -v gdrive1:test1 gdrive2:test2 --drive-v2-download-min-size 100M

on 1.44-1.50.1 without v2

rclone copy -v gdrive1:test1 gdrive2:test2

There's no difference between v2 and v2 disabled. But on 1.39, the speeds are 6 times faster.

Debug log would be superb too with "-vv".

Its fine, I solved it by using --drive-chunk-size=256M after many trial and errors. Its fast again on 1.50.1. Not using v2 either. Consider this solved.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.