--drive-team-drive switch overrides crypt settings


#1

So, I have a crypt remote set up on my google drive, and was trying to transfer some files from that mount to a team drive, using the --drive-team-drive switch. However, when I specify a team drive in that manner the crypt remote gives me “error reading source directory: directory not found”. I know the directory exists and confirmed it with lsf. What’s more, when I manually created a team drive remote instead of using the command line switch, the transfer worked perfectly fine. I assume what’s happening is the crypt remote is trying to look in the team drive instead of where it was originally configured to look.

Should this be happening? And furthermore, is it at all possible to make the --drive-team-drive switch only apply to the next remote listed (e.g. to transfer between two team drives or a personal drive and a team drive).

Reproduction steps:
Three remotes: a crypt remote on google drive, a drive remote, and a drive remote configured as a team drive.
Try to transfer from the crypt remote to the team drive using the drive remote and the --drive-team-drive switch. It will fail.
Do the same, using the same paths, using the drive configured as a team drive without the switch, and it will work.


#2

Yes the --drive-team-drive switch will apply to all drive backends.

You can work around this by setting an enviroment variable instead, eg

export RCLONE_CONFIG_REMOTENAME_DRIVE_TEAM_DRIVE=xxx

Where REMOTENAME is the name of your remote in small or capital letters.


#3

Thanks, that’s useful.

edit: Looks like it’s RCLONE_CONFIG_REMOTENAME_TEAM_DRIVE=xxx , matching the config file option rather than the command line one.

edit2: Also seems like it needs to be ALL_CAPS.


closed #4

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.