Drive mount, read error low level

What is the problem you are having with rclone?

I have created the oauth authorization for a friend of mine. He's not tech-savy, so he shared his password with me (we are very good friends and in the same Drive organization) and I did a full configuration for a Drive mount for him. Passed him the resulting rclone.conf and a batch file to launch the mount.
Before doing this I tested the mount and I was able, from my machine, to access Drive, copy files, etc.
He copied the files I passed to him, installed WinFsp (Windows 10 machine) launched the batch file and the mount appeared. Files and folders are listed correctly.
But if he tries to access files... either the program accessing them crashes/hangs or the copy dialog appears and never makes any progress. No network traffic, nothing.

The following appears in log after trying to copy a file from Drive to a local drive. I'll provide verbose log if needed but for now this is what I have:

The service rclone has been started.
2020/05/13 16:28:44 ERROR : RANDOMVIDEO.avi: ReadFileHandle.Read error: low level retry 1/10: read tcp> wsarecv: Connessione in corso interrotta forzatamente dall'host remoto.
2020/05/13 16:46:34 INFO  : Starting HTTP transaction limiter: max 10 transactions/s with burst 1

Again I stress: the very same .conf file with the same credentials and same mount command line works just fine. We tried disabling the firewall on his PC to no avail (but rclone uses port 443 so I doubt the firewall could be the problem in any case).

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 x164

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gDrive: Q: --allow-other --allow-root --tpslimit 10 --fast-list --dir-cache-time 96h --vfs-read-chunk-size 128M --buffer-size 64M --log-level INFO --config C:\Users\USERNAME\.config\rclone\rclone.conf --log-file E:\WIP\rclone\rclone.log --timeout 1h


--allow-other does nothing on windows, so you can remove it.
--allow-root not sure that does anything on windows, i have never used it.

can you share the log file?

As I mentioned, I do not currently have access to my friend's machine but the log displayed an error, which I already pasted in the OP.

what version of winfsp?

how are you running the mount?

  • standard user permissions?
  • administrator level permissions?
  • system user permissions?

what if rclone ls gDrive:?

program accessing them crashes.

what is the error or dialog box, what program?


So far the above mounting command was issued through a batch file, on a double click, no admin permissions were requested, hence I guess none were granted. Again: Drive content are displayed correctly on the mount, all directories, all files. The problem comes only when accessing them or trying to copy them locally.

I don't currently have access to the machine where the problem is found but I would suspect it would work correctly, considering that the Q: drive is mounted and its contents displayed correctly in Explorer.

hmm, thanks for that info, this is strange?

i normally do not use this flag but i have found it helpful sometimes

when that app is crashes, what is the error and/or dialog box?

can you translate the error to english?
is this correct?
"An existing connection was forcibly closed by the remote host"

Yes, translation is correct, I'd say.

if on both machines are running

  • same rclone version
  • same winfsp version
  • same operating system
  • same rclone command
  • run the same way
  • "An existing connection was forcibly closed by the remote host" which is a common error on windows.

then it would seem to be an issue with that user's computer, internet connection or some other non-rclone glitch.

given that the computer is running, have you rebooted the computer and tried again?

Have your friend try a simple mount command, like this:

rclone mount --buffer-size 256M --dir-cache-time 1000h --timeout 1h -v

or, if read-only is desired:

rclone mount --attr-timeout 1000h --buffer-size 256M --dir-cache-time 1000h --poll-interval 0 --read-only --timeout 1h -v

The latter is what I use in Windows on a daily basis.

I'd say this is likely some kind of firewalling problem.

Nah, this happens randomly while using Plex. I get this and the "unexpected EOF" every once in a while. They can both be ignored IMO, unless they happen too frequently, or like in his case, non-stop :wink:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.