Downgrade rclone to older version

Hi all, I am having problems with v1.40 sync with Backblaze, originally I was using v1.36 and all worked perfectly, I have reinstalled the server now (CentOS7) and installed the latest version 1.40 and it does not work.

So I set up a test server and installed 1.36 all good again, so how do I downgrade from 1.40 to 1.36 on the production server, obviously I don’t want to reinstall again.


In what way doesn’t it work?

How did you install rclone? It is a single binary so it should just be a matter of moving the old binary out the way and copying the new one in.

In what way doesn’t it work?

Nothing copied to Backblaze, I have spent several days trouble shooting the issue, and after testing v1.36 again and it works perfectly, so I have decided that’s the best option as that version backed up every 12 hours for almost a year and never failed.

How did you install rclone?

By following this page

If you send a log then I can debug it and find out what is happening!

Just follow those instructions again but with the v1.36 download and all should be well.

Where can I find the log file you need?

If you could just run a transfer that fails, putting -vv --log-file /tmp/rclone.log on the command line then it will output a log to /tmp/rclone.log. If small you can paste it here, or you can put it on pastebin (or email it to me with a link to the forum post for context). Thanks!