Docker plugin concurrency limiting

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

I am using Hetzner's SFTP storage box BX11 and it has 10 concurrent connection limit and transfers and checkers defaults are 4 and 8, so I assume that 12 is hitting connection cap.
I get a connection cap error if trying to connect from other devices.
I tried to add transfers and checkers options limiting them to 1 but I got unsupported backend option

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.0

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-1049-oracle (aarch64)
  • os/type: linux
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.21.4
  • go/linking: static
  • go/tags: snap

Which cloud storage system are you using? (eg Google Drive)

SFTP

The command you were trying to run (eg rclone copy /tmp remote:tmp)

docker compose file

volumes:
  rclone-volume:
    driver: rclone
    driver_opts:
      # source: your_sftp_alias:your_sftp_path
      # destination: /local/path
      type: sftp
      sftp-user: ${SFTP_USER}
      sftp-pass: ${SFTP_PASSWORD_OBSCURED}
      sftp-host: ${SFTP_HOST}
      # checkers: 1
      # transfers: 1
      allow-other: 1

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

NOTICE: Config file "/home/ubuntu/snap/rclone/487/.config/rclone/rclone.conf" not found - using defaults
; empty config
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

 ✘ Volume "rclone-volume"  Error                                                                                                                         0.0s 
Error response from daemon: create rclone-volume: VolumeDriver.Create: unsupported backend option "checkers"

welcome to the forum,

checkers is a global flag, not a backend flag.

so i believe you need to use args, something like
args="checkers=1 transfers=1"

You can also use this (which can go in the config file)

  --sftp-concurrency int   The maximum number of outstanding requests for one file (default 64)

Its really easy to deadlock rclone with this though so setting --checkers and --transfers is best, but I'm not sure how well they work with the docker plugin.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.