Disable=move connection string is not represented in backend features

What is the problem you are having with rclone?

rclone backend features with disable=move in the connection string does not do what is expected. --disable move does.

What is your rclone version (output from rclone version)

rclone v1.56.0
- os/version: darwin 10.15.7 (64 bit)
- os/kernel: 19.6.0 (x86_64)
- os/type: darwin
- os/arch: amd64
- go/version: go1.16.6
- go/linking: dynamic
- go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

macOS 10.15.7 x86

(side note, I guess this question really isn't needed anymore since it is in the version output)

Which cloud storage system are you using? (eg Google Drive)

Local. Haven't tested others

The command you were trying to run (eg rclone copy /tmp remote:tmp)

$ rclone backend features --disable move "test:"

{
	"Name": "local",
	[...]
	"Features": {
               [...]
		"Move": false,
               [...]
	}
}

And

$ rclone backend features "test,disable=move:"

{
	"Name": "local",
	[...]
	"Features": {
               [...]
		"Move": true,
               [...]
	}
}

The rclone config contents with secrets removed.

I also tested without a config but I decided to make an alias to be a bit easier and representative in my code.

[test]
type = alias
remote = .

A log from the command with the -vv flag

N/A -- See above

Hi Justin,

It looks like you have hit this limitation:

Note that the connection string only affects the options of the immediate backend. If for example gdriveCrypt is a crypt based on gdrive, then the following command will not work as intended, because shared_with_me is ignored by the crypt backend:

rclone copy "gdriveCrypt,shared_with_me:shared-file.txt" gdriveCrypt:

Source: https://rclone.org/docs/#connection-strings

The limitation stumbled me too while preparing tests for #5341 - and lead to my above addition to the docs :wink:

--disable is a global command line flag, not a backend specific flag, so it can't be used in connection strings.

I agree it would be nice to apply --disable elements to just a specific backend, but rclone doesn't have the configuration syntax to allow that at the moment.