Dedupe mode- rename

Trying to use dedupe interactive to rename files instead of deleting

but everytime I run it- the 2nd file will just get deleted instead of being renamed.

Have tried - rclone dedupe --dedupe-mode interactive "remote:"
also tried -rclone dedupe --dedupe-mode interactive "remote:" -i

Which also only gives options of deleting- see below-
rclone: delete "test.pdf"?
y) Yes, this is OK (default)
n) No, skip this
s) Skip all delete operations with no more questions
!) Do all delete operations with no more questions
q) Exit rclone now.

How can I get it to rename?

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.2

  • os/version: Microsoft Windows 10 Pro 21H2 (64 bit)
  • os/kernel: 10.0.19044.2006 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.18.6
  • go/linking: static
  • go/tags: cmount

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads

Which cloud storage system are you using? (eg Google Drive)

Google Drive and backing up to inhouse storage using SFTP

Can you recreate the issue and share a debug log file - command with -vv and share the full output?

From the docs

rename removes identical files then renames the rest to be different

If you have two identical files which have

  • identical file names
  • identical sizes
  • identical hashes

Then rclone will just remove one - no need to keep a copy of an identical file.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.