DB upload crypt issues

Issue: uploading to Crypt and File name encoding is appearing in chinese txt EG.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-73-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Rclone config

The rclone config works fine, tested using windows wsl. Files copy correctly.

Rclone log

actually it is not chinese:) even if you see chinese characters.

The clue is in your config:

filename_encoding = base32768

This encoding uses 32768 different characters to encode binary data in filenames. As there is much more south east asian characters than any other it is what you mostly see.

File name is encrypted -> result is binary string -> to save it as a file name you have to encode it.

You can read more:

ok I was just comparing it to the same output from windows doing the same job. it instead produces file name like"vqj6qq0t69fcbltjjcbhm6ts38" Assuming then that I should expect the same result

It does not matter windows or not. What matters is what you ask rclone to use.

You asked to use base32768. So you see a lot of character in filenames - 32768 to be exact.

Windows run rclone will produce exactly the same result if you use the same settings.

1 Like

cheers, thanks for the explanation, just a little unsure. Wanted to make sure everything is ok. I can see the files correctly when they are decoded. it seems that it is fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.