Daily ACD API limit?


#1

Does anyone know the daily API limit of ACD?

In the last 3 weeks I started having issues. I cannot access any of my files on any of the apps I use ACD on, including their own apps.

I didn’t change anything in the last 2-3 months so it’s a bit strange that it keeps happening…

I did a

rclone.exe -vv --dump-bodies copy “acd:stuff” D:\stuff

and I got:

{}
2017/11/05 22:35:50 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2017/11/05 22:35:50 DEBUG : pacer: Rate limited, sleeping for 225.842738ms (1 consecutive low level retries)
2017/11/05 22:35:50 DEBUG : pacer: low level retry 1/10 (error HTTP code 429: “429 Too Many Requests”: response body: “{}”)
2017/11/05 22:35:50 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2017/11/05 22:35:50 DEBUG : HTTP REQUEST (req 0xc0422ec400)
2017/11/05 22:35:50 DEBUG : GET /cdproxy/nodes/****/content HTTP/1.1
Host: content-eu.drive.amazonaws.com
User-Agent: rclone/v1.37
Authorization: XXXX
Accept-Encoding: gzip

2017/11/05 22:35:50 DEBUG : >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
2017/11/05 22:35:50 DEBUG : <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2017/11/05 22:35:50 DEBUG : HTTP RESPONSE (req 0xc0422ec400)
2017/11/05 22:35:50 DEBUG : HTTP/1.1 429 Too Many Requests
Content-Length: 2
Connection: keep-alive
Content-Type: application/json
Date: Sun, 05 Nov 2017 20:35:49 GMT
Server: Amazon-Cloud-Drive
X-Amzn-Requestid: -***-***-***-

Amazon support is of no help, they keep sending me off to amazon.es, since I made my account there, a few years ago, but I don’t speak Spanish well enough to be able to explain my issue…

Any help is appreciated!


#2

I am having the same 429 issues as you are experiencing.

@ncw, does ACD need anything like tpslimit as Gdrive does?


#3

It is probably worth experimenting with tpslimit - as the cloud storage providers grow they put in more and more rate limiting and tpslimit is designed to help with that.


#4

FYI… I limited the tpslimit and the tpslimit burst to 1 and the issue seems to be solved by now.


#5

@ncw, it just seemed solved. Today it happened again.
It seems that when this happen the access is blocked for a certain time because even if I stop everything the remount the drive the first file a try to access it immediately shows the 429 error.

Do you have any idea what this could be?

€dit: I tried to download files from my ACD using the WebGUI and the official Amazon App but the result is the same. I can’t download any file from my ACD.

Contacted the Amazon Support right now, will report back when I hear from them.


#6

I disabled a lot of things under scheduled tasks in plex and I haven’t had issues since.

I have pihole on the plex server so I could see that plex made 15-20000 DNS queries to amazon servers in a day. Now it does as many as emby.

Still, I had that many queries in the last 3-4 months and there wasn’t an issue. Plus it is really annoying that they limit even their own apps…


#7

What kind of things if I may ask?

Actually, I am already using Emby. Besides some testing I never used Plex.

I’m afraid they won’t tell why exactly this error occurs and yes, blocking their own apps is not very smart imo.

€dit: This seems to be a 24-hours ban. It’s the second time that after 24 hours the ban was lifted.


#8

FYI…

In my case the cause of the 429 errors seemed to be all the frameart files of Emby.

In the first place I had all these information/files stored in ACD and there were a lot of file requests caused by that.
Now they are stored directly on the server and for now I haven’t had this issue for a week (at least).