Couldn't find root directory ID: dial tcp: lookup no such host

What is the problem you are having with rclone?

Whenever I run rclone copy or sync, rclone says it can't find the root directory ID: and "no such host", then fails. All of my directories are valid so not sure what is happening.

I tried running "rclone config reconnect gdrive:" but the same error happens once I run the sync or copy command again.


Run the command 'rclone version' and share the full output of the command.

C:\Users\MutantMarineServer\Documents\rclone>rclone version

rclone v1.62.2

  • os/version: Microsoft Windows 10 Pro 22H2 (64 bit)
  • os/kernel: 10.0.19045.3086 Build 19045.3086.3086 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync gdrive:Videos "F:\Videos" --progress --transfers=10 -vv

The rclone config contents with secrets removed.

type = drive
scope = drive
token = {"access_token":"xxxxxxxxxxxxxxxxxxx.not.the.real.password","expiry":"2023-06-23T11:56:41.9079826+09:00"}
team_drive = 

type = crypt
remote = "gdrive:Encryption/Encrypted Rclone"
password = xxxxxxxxxxxxxxxxx.not.the.real.password

A log from the command with the -vv flag

C:\Users\MutantMarineServer\Documents\rclone>rclone sync gdrive:Videos "F:\Videos" --progress --transfers=10 -vv
2023/06/23 10:58:02 DEBUG : rclone: Version "v1.62.2" starting with parameters ["rclone" "sync" "gdrive:Videos" "F:\\Videos" "--progress" "--transfers=10" "-vv"]
2023/06/23 10:58:02 DEBUG : Creating backend with remote "gdrive:Videos"
2023/06/23 10:58:02 DEBUG : Using config file from "C:\\Users\\MutantMarineServer\\AppData\\Roaming\\rclone\\rclone.conf"
2023/06/23 10:58:13 Failed to create file system for "gdrive:Videos": couldn't find root directory ID: Get "": dial tcp: lookup no such host

That's a local device issue / firewall / dns / AV / etc.

What should I allow on my firewall that will not block the connection?

Sorry - Not a windows guy so I'd do a few searches to see.

the windows firewall, by default, will not block that.

can you ping

Here is the result:


Pinging [] with 32 bytes of data:
Reply from bytes=32 time=77ms TTL=112
Reply from bytes=32 time=79ms TTL=112
Reply from bytes=32 time=77ms TTL=112
Reply from bytes=32 time=79ms TTL=112

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 77ms, Maximum = 79ms, Average = 78ms

how about rclone lsd gdrive: -vv

C:\Users\MutantMarineServer\Documents\rclone>rclone lsd gdrive: -vv
2023/06/25 23:09:35 DEBUG : rclone: Version "v1.62.2" starting with parameters ["rclone" "lsd" "gdrive:" "-vv"]
2023/06/25 23:09:35 DEBUG : Creating backend with remote "gdrive:"
2023/06/25 23:09:35 DEBUG : Using config file from "C:\Users\MutantMarineServer\AppData\Roaming\rclone\rclone.conf"
2023/06/25 23:09:36 DEBUG : Google drive root '': 'root_folder_id = xxxx(not.real)' - save this in the config to speed up startup
-1 2018-01-01 16:10:42 -1 xxx
-1 2017-09-23 07:49:35 -1 xxx
-1 2021-05-08 14:25:31 -1 xxx
-1 2017-09-27 13:35:47 -1 xxx
-1 2017-09-23 07:49:51 -1 xxx
-1 2017-09-30 14:23:48 -1 xxx
-1 2017-09-23 07:49:08 -1 xxx
-1 2020-01-14 14:35:58 -1 xxx
-1 2019-09-23 11:23:09 -1 xxx
-1 2019-02-05 00:35:45 -1 xxx
-1 2017-09-23 07:48:15 -1 Videos
-1 2017-09-23 07:48:43 -1 xxx
2023/06/25 23:09:36 DEBUG : 4 go routines active

I think I may have an answer but not sure. Whenever my CPU usage is around 100%, I tend to get these errors more often. Not sure why that would happen though. Sometimes it'll be copying files over, then it'll fail and say that error message. Here's another error code with the verbiage a little different:

2023-06-25 17:43:26 ERROR : PC/Games/xxxx/WILD.BMP: Failed to copy: failed to open source object: open file failed: Get "": dial tcp: lookup getaddrinfow: This is usually a temporary error during hostname resolution and means that the local server did not receive a response from an authoritative server.

Network overload maybe?

if you push a machine to the limit, bad stuff happens.
looks like an issue with dns servers

what happens after the error?
rclone sync retries and continues to run or rclone exits with error code?

Almost for sure this is not rclone problem. By any chance do you have any anti virus/malware software installed? If yes turn it off and try again. It is very often root cause of issues like this.

Only Windows Defender, and I have that disabled in the regedit.

Windows Defender is actually only one trouble free - I always keep it on - no issues. You should have a look what is causing 100% CPU usage as rclone is not so power hungry. IMHO answer is somewhere in your system and has nothing to do with rclone. Something is causing DNS service to become unresponsive.

It retries and sometimes works, but does not consistently succeed. I've set my DNS to and for my primary/alternate.

might be so many issues that it is impossible to guess - but you can try and - this is what I always use staying away from Google as far as possible:)

You can also open terminal window and run:

ping -t


ping -t > logfile.txt

it will run "forever" so you can see if there are some temporary glitches with networking.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.