Corrupted files with windows net drive

Seems not:
Linux hostname 5.13.0-30-generic #33~20.04.1-Ubuntu SMP Mon Feb 7 14:25:10 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

That's it as I'm running HWE as well.

apt search linux-generic-hwe-20.04
Sorting... Done
Full Text Search... Done
linux-generic-hwe-20.04/focal-updates,focal-security,now amd64 [installed]
  Complete Generic Linux kernel and headers

Was just curious as that's pretty recent. Samba always been odd imo but not a rclone item so not sure what else to suggest.

I didn't realized that the kernal coudl be an issue. Thanks for the hint!

I was just able to reproduce it. In fact I tried with different --transfers.
There was not error with --transfers=1, but there was error with --transfers=2.

I also feel that the error could be on the server side.
I'm just surprised that it's not a transfer error during the transfer, but rclone found it by verifying it afterwards.

I think this is unlikely to be an rclone problem.

I suspect that samba is getting confused somehow when doing multiple copies at once.

Upgrading samba and the kernel on the Ubuntu box might help.

That said, because rclone does verify after copy, you can probably really on the retries to clean everything up.

I agree. I have also tried with a few other samba servers, which worked fined.
So likely there's something wrong on my machine.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.