Copying file to backblaze either fails silently or fails to create file system

What is the problem you are having with rclone?

rclone copy command fails to copy to remote

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux Ubuntu 20 (Mate) 64 bit

Which cloud storage system are you using? (eg Google Drive)

Backblaze B2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /mnt/8TB/ backblazeb2
rclone copy /mnt/8TB/ remote:backblazeb2

The rclone config contents with secrets removed.

type = b2
account = 001f234df510a1b0000000001
key = <this is an alphanumeric key>
hard_delete = true
versions = false
type = b2
account = <acctstring>
key = <keystring>
hard_delete = true
endpoint =```

Sorry this post is a bit confusing because I deleted the old config and made a new one and generated a new key pair as well. The new config also includes an endpoint.

#### A log from the command with the `-vv` flag  
<!-- You should use 3 backticks to begin and end your paste to make it readable.  Or use a service such as or   -->

I cannot find any log file. When I try the first version it seems to fail silently, but I think it actually makes a directory called backblazeb2 and copies my file to it locally. When I try the second command I get an error message: "Failed to create file system for  "remote:backblazeb2": didn't find section in config file"

I am running rclone as root in the /root directory and my config file location is /root/.config/rclone/rclone.conf. I tried using the --config option but it didn't help. They keypair is an application keypair and not a master keypair.

After a bit more research I see that the remote dir is supposed to be in the form of [configname]:[bucket]. So in my case this would be "blaze:sliceofheaven". When I enter the command: ```rclone copy /mnt/8TB/ blaze:sliceofheaven -vv``` I get the following:
```2020/05/18 15:01:50 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "copy" "/mnt/8TB/" "blaze:sliceofheaven" "-vv"]
2020/05/18 15:01:50 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2020/05/18 15:01:50 Failed to create file system for "blaze:sliceofheaven": failed to authorize account: failed to authenticate: Get unsupported protocol scheme ""

I think if you delete this line from your config then it will work properly

1 Like

hello and welcome to the forum,

when using remotes, you need to have a colon appended to the name of the remote
rclone copy /mnt/8TB/ backblazeb2:

this will not work, as the of the remote is backblazeb2:, not remote:

you can test this by
rclone ls backblazeb2:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.