Changing GDrive Permissions

Overview of my setup:

  • Encoding Server - Plex, PlexDrive, Rclone w/ 2 encrypted mounts. Everything handled by root user
  • Seedbox - Sonarr/Radarr, Plexdrive, Rclone w/ same encrypted mounts. Everything handled by ‘UserA’ with root privileges

Everything has worked in the past before I split this setup onto two servers, which makes sense. However with this new configuration, when mounting those encrypted mounts on my seedbox, I’ve noticed the folder and group ownerships are set to root:root which is making, primarily Sonarr, not work, as ‘UserA’ is unable to move content into those folders due to permissions.

My question is this: Is there any way to change the file/folder permissions during mount? And if so, would that potentially screw up my plex server while doing so?

Things I’ve tried: Manually changing owner permissions, to ‘UserA’ this seems to crash the SSH session and possibly server.

For what it’s worth, guide I’ve used

I’ve resolved this issue, by reading the guide a little more thoroughly! Set this thing up so many times I just skim through it.


If you run into an issue with sonarr unable to write to the folder, you’ll have to recreate the file structure/ownership within /home/plex/tv-r. Unmount via fusermount -uz /home/plex/fuse-tv and comment out the crontab entry for fuse while we make this change. This code below will copy all folders only and no files from your /home/plex/tv-gd to your /home/plex/fuse-tv then via fuse it will carry over to /home/plex/tv-r

cd /home/plex/tv-gd && find . -type d -exec mkdir -p -- /home/plex/tv-r/{} \;

chown -R username:username /home/plex/tv-r