Change --vfs-cache-max-size with remote control

I am sorry if this is a stupid question. I was reading the documentation and the forum up and down, but I can't figure it out.

suppose I have a mount
rclone mount crypt2: /mnt/shared/fusemounts/SB/ --allow-other -v --fast-list --buffer-size=16M --vfs-cache-mode full --dir-cache-time 172h --vfs-read-chunk-size 16M --vfs-read-chunk-size-limit 512M --vfs-cache-max-age 5000h --vfs-cache-poll-interval 10m --umask 0 --vfs-write-back 5m --cache-dir /mnt/shared/media/cache/ --vfs-cache-max-size 1T --rc --rc-addr :55742 --rc-user whiteloader --rc-pass secretpass

Now I am trying to change the --vfs-cache-max-size to 1.5T with remote control. This is the command I am trying and it's failing. My syntax is the best I could come up with and I'd appreciate if you could tell me how to use it properly

rclone rc --rc-addr :55742 --rc-user whiteloader --rc-pass secretpass -o vfs-cache-max-size=1.5T

What is the problem you are having with rclone?

want to change mount parameters with RC

What is your rclone version (output from rclone version)

rclone v1.54.0

  • os/arch: linux/amd64
  • go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

ubuntu18.04 x64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

You can do something like:

 rclone rc options/set --json '{"vfs": {"CacheMaxSize": 805305955683}}'

That's in bytes to about 750GB.

Thank you.
That looks promising, however I am not able to get it to work unfortunately :frowning:

After executing I simply get the answer


and nothing else happens

whiteloader@whiteloader:~:$ rclone rc options/set --json '{"vfs": {"CacheMaxSize": 1649267441664}}' --rc-addr :55742 --rc-user whiteloader --rc-pass secretpass

I think that means it worked.

However I'm not sure setting the cache max size like that will do what you want. It sets the default for the next VFS to be built, but doesn't change the existing one.

In fact I don't think that is possible at the moment without restarting the VFS.

Thank you for the clarification. Maybe it worked (?) indeed - however not in a way I was hoping it would, as you have pointed out. I checked Cache space consumption and can confirm it didn't change anything.

It's a bit sad that it is not possible but I least now I know there is no point in trying further.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.