Cant sync with onedrive student account

I cant configure rclone to sync with my onedrive office student account, it gives me this error when it tries to authenticate my account:

"Error: Auth Error

Description: No code returned by remote server"

rclone version: 1.51/amd64 64bits. Downloaded zip version for linux.

Procedure I am doing on ubuntu 20.04 terminal:

rclone config
*No remotes found - make a new one
name> onedrive
storage>23 (which is the option for Microsoft Onedrive
client id>
*Edit advanced config? (y/n)
Use auto config?
If your browser doesn't open automatically go to the following link: Deleted because cant post link... but its the default by rclone
*Log in and authorize rclone for access
*Waiting for code...
*2020/05/13 21:15:55 Failed to configure token: Error: Auth Error
*Code: ""
*Description: No code returned by remote server

EDIT UPDATE: When I give my client ID to rclone (which I got on Azure Microsoft Portal) it gets me this message on the authorization step:
"AADSTS50194: Application 'My client ID'(P2P Server) is not configured as a multi-tenant application. Usage of the /common endpoint is not supported for such applications created after '10/15/2018'. Use a tenant-specific endpoint or configure the application to be multi-tenant."

I tried to modify the permission of my client, but I don't allow me to do so.
Then, I tried creating a new app registration inside my azure portal, which I can... but it ends up on the first error I was receiving when I didn't use my client id.

Any thoughts?

Have a go with the latest beta and see if that helps. We made some improvements to the storage selection part of this code.

I tried installing it by:

curl | sudo bash -s beta

Is that right?

Haven't worked either, the same problem happens.


can you post rclone version

are you running rclone config on a command line terminal.
if so, have you seen this?

rclone version: 1.51/amd64 64bits. Downloaded zip version for linux.

Yes, I am doing it all through command line.
I take a look at your link, but I don't think it applies to me since I am not using a remote machine. But I did tried the process and got stuck on the same step: It doesn't give authorization by the browser link,

that does not look like a beta version, can you post the actual output of rclone version
it would look like

rclone v1.51.0-264-g2696e369-fix-4104-cwd-disappears-beta
- os/arch: windows/amd64
- go version: go1.14.2

you wrote "tried the process"
which one of the processes did you try?
as per that link "There are two ways of doing it"

I installed with this command, I believe it downloads and install the earliest beta version. Dont know how to check it.

All the process in this link necessarily needs me to authorize rclone through a link, which I cant. I did an update on the post about it. When I set my client id, it gives me a different error.

I am trying to solve the problem through azure portal by creating permissions in my account. But so far I am guessing I don't have a lot of permission privileges since I have a student account.

I believe the problem is with onedrive permissions and not with rclone. But I haven't figured it out yet.

Type "which rclone'". I bet you have two installed and it's using the older one. The new one will go to /usr/bin

can you run rclone version and post the output?
this is let us know the exact version you are using.

rclone v1.51.0-320-g52b7337d-beta

  • os/arch: linux/amd64
  • go version: go1.14.2

good. thanks...

have you tried this?

Have you tried the headless option? Auto-config no.

@asdffdsa @calisro

I believe I am a bit lost into this process.

I type auto-config with the "no" option.
It asks me to run "rclone authorize "onedrive" on my machine.
So I just open a new terminal and type it? Dont really got it.

And for the command "rclone config file" it answers me that, since I couldn't create it:
"Configuration file doesn't exist, but rclone will use this path:

if you have a desktop computer with a gui and web browser, then run rclone config on that computer,
then copy the rclone.conf from desktop computer to headless computer

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.