Can't run the sync command on a destination with the string "sync" in its path

What is the problem you are having with rclone?

Can't run the sync command on a destination with the string "sync" in its path. The same problem is encountered when running the copy command as well.

Run the command 'rclone version' and share the full output of the command.

- os/version: Microsoft Windows 11 Home 22H2 (64 bit)
- os/kernel: 10.0.22621.1413 Build 22621.1413.1413 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

.\rclone.exe sync K:\"My desktop sync"\ KoofDesk:"My desktop sync"\ --dry-run

The rclone config contents with secrets removed.

type = koofr
provider = koofr
user = example@email.example
password = password

A log from the command with the -vv flag

  rclone sync source:path dest:path [flags]

      --create-empty-src-dirs   Create empty source dirs on destination after sync
  -h, --help                    help for sync

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command sync needs 2 arguments maximum: you provided 3 non flag arguments: ["K:\\My desktop sync\" KoofDesk:My" "desktop" "sync\""]

You have some quirky backslashes in there with the quotes which is breaking the quotes.


rclone.exe sync K:"My desktop sync" KoofDesk:"My desktop sync" --dry-run
1 Like

The bug persists, but a workaround is to create an alias remote with the offending path and use that as a parameter instead.

That does not seem right as your initial command won't work as it's not formatted properly.

My bad. I tried again on a subdirectory and forgot to enclose the space-containing folder names with quotation marks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.