Can't purge vfs cache

I mounted a google drive remote, and was using Firefox to download directly to the mount (using --vfs-cache-mode writes).

Rclone crashed during this process, but it does not appear to have cleared the cache db, based on the remaining space on my hard drive.

Running with --cache-db-purge has not freed up any space.

  1. Any suggestions on reclaiming this space?
  2. Where is the default vfs cache directory on MacOS?

That's for the cache backend and is not related to the VFS caching setup.

cache-dir is what you are looking for and by default it should with your rclone.conf location.

It's not with rclone.conf on MacOS apparently.
Just going to post this here for reference (as I don't think it's in the docs)

I tried:

rclone mount crypt: ~/Desktop/rclone --vfs-cache-mode writes --vfs-cache-max-age 10s -vv

with the thought that if I couldn't clear the vfs cache manually (or find it) that rclone would just purge the cache on its own after 10 seconds. That did not work.

Then I ran:
rclone mount crypt: ~/Desktop/rclone --vfs-cache-mode writes --vfs-cache-max-age 10s -vv

The console output with -vv was different:

2020/02/20 12:00:34 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "mount" "crypt:" "/Users/lebowski/Desktop/rclone" "--vfs-cache-mode" "full" "--vfs-cache-max-age" "10s" "-vv"]**

2020/02/20 12:00:34 DEBUG : Using config file from "/Users/lebowski/.config/rclone/rclone.conf"

2020/02/20 12:00:36 DEBUG : Encrypted drive 'crypt:': Mounting on "/Users/lebowski/Desktop/rclone"

2020/02/20 12:00:36 DEBUG : vfs cache root is "/Users/lebowski/Library/Caches/rclone/vfs/crypt"

The bolded line did not appear in the console output when I ran with --vfs-cache-mode writes, only when I ran with --vfs-cache-mode full

I deleted the entire contents of ~/Library/Caches/rclone/vfs/ and restored about 9GB of space.

It should have done - it is printed when the cache is created and it is created on any --vfs-cache-mode other than off.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.